<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /> <script>window.adthrive = window.adthrive || {};
window.adthrive.cmd = window.adthrive.cmd || [];
window.adthrive.host = 'ads.adthrive.com';
window.adthrive.plugin = 'adthrive-ads-1.0.37';
window.adthrive.threshold = Math.floor(Math.random() * 100 + 1);

(function() {
	var script = document.createElement('script');
	script.async = true;
	script.type = 'text/javascript';
	script.src = 'https://ads.adthrive.com/sites/55cca79b52c946be6dac61bd/ads.min.js?threshold=' + window.adthrive.threshold;
	var node = document.getElementsByTagName('script')[0];
	node.parentNode.insertBefore(script, node);
})();</script> <link media="all" href="https://thewoksoflife.com/wp-content/cache/autoptimize/css/autoptimize_a8852cb3b115a83f0723baf1bc285bb1.css" rel="stylesheet" /><title>Pork Ribs with Black Bean Sauce | The Woks of Life</title><meta name="description" content="Pork ribs with black bean sauce is a Chinese comfort food recipe, perfect as a one-plate meal. Prep the ribs beforehand, and make this dish in minutes!" /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Pork Ribs with Black Bean Sauce | The Woks of Life" /><meta property="og:description" content="Pork ribs with black bean sauce is a Chinese comfort food recipe, perfect as a one-plate meal. Prep the ribs beforehand, and make this dish in minutes!" /><meta property="og:url" content="https://thewoksoflife.com/pork-ribs-black-bean-sauce/" /><meta property="og:site_name" content="The Woks of Life" /><meta property="article:publisher" content="https://www.facebook.com/thewoksoflife" /><meta property="article:author" content="facebook.com/thewoksoflife" /><meta property="article:published_time" content="2020-06-01T04:01:36+00:00" /><meta property="article:modified_time" content="2020-06-01T18:19:46+00:00" /><meta property="og:image" content="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17.jpg" /><meta property="og:image:width" content="650" /><meta property="og:image:height" content="849" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Pork Ribs with Black Bean Sauce" /><meta property="og:description" content="Pork ribs with black bean sauce is a Chinese comfort food recipe, perfect as a one-plate meal. Prep the ribs beforehand, and make this dish in minutes!" /><meta property="og:url" content="https://thewoksoflife.com/pork-ribs-black-bean-sauce/" /><meta property="og:site_name" content="The Woks of Life" /><meta property="og:updated_time" content="2020-06-01T14:19:46+00:00" /><meta property="article:published_time" content="2020-06-01T00:01:36+00:00" /><meta property="article:modified_time" content="2020-06-01T14:19:46+00:00" /><meta property="og:image" content="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17.jpg" /><meta property="og:image:width" content="650" /><meta property="og:image:height" content="849" /><meta property="article:author" content="facebook.com/thewoksoflife" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:title" content="Pork Ribs with Black Bean Sauce" /><meta name="twitter:description" content="Pork ribs with black bean sauce is a Chinese comfort food recipe, perfect as a one-plate meal. Prep the ribs beforehand, and make this dish in minutes!" /><meta name="twitter:image" content="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17.jpg" /><meta name="twitter:creator" content="@thewoksoflife" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Woks of Life &raquo; Feed" href="https://feeds.feedburner.com/thewoksoflife" /><link rel="alternate" type="application/rss+xml" title="The Woks of Life &raquo; Comments Feed" href="https://thewoksoflife.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="The Woks of Life &raquo; Pork Ribs with Black Bean Sauce Comments Feed" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thewoksoflife.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='dashicons-css' href='https://thewoksoflife.com/wp-includes/css/dashicons.min.css?ver=5.3.3' type='text/css' media='all' /><link rel='stylesheet' id='daily-dish-google-fonts-css' href='//fonts.googleapis.com/css?family=Alice%7CLato%3A400%2C700%2C900&#038;ver=1.0.26' type='text/css' media='all' /><link rel='stylesheet' id='fontawesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' /><link rel='stylesheet' id='gppro-style-css' href='https://thewoksoflife.com/wp-content/cache/autoptimize/css/autoptimize_single_691e236f70f53d79c7fbb9f9d6486174.css?ver=1466212867' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://thewoksoflife.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <link rel='https://api.w.org/' href='https://thewoksoflife.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thewoksoflife.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thewoksoflife.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://thewoksoflife.com/?p=39997' /><link rel="alternate" type="application/json+oembed" href="https://thewoksoflife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthewoksoflife.com%2Fpork-ribs-black-bean-sauce%2F" /><link rel="alternate" type="text/xml+oembed" href="https://thewoksoflife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthewoksoflife.com%2Fpork-ribs-black-bean-sauce%2F&#038;format=xml" /><meta property="slick:wpversion" content="1.1.6" /> <script>/* Slickstream Engagement Suite Embedder */
"use strict";((e,t,c)=>{const i=window;i.slickSnippetVersion="1.18.0";i.slickSnippetTime=(performance||Date).now();i.slickEmbedRoot=e;i.slickSiteCode=c;let a;const n=async e=>{if(!a&&"caches"in self){try{a=await caches.open("slickstream1")}catch(e){console.log(e)}}let t;if(a){try{const c=new Request(e);t=await a.match(c);if(!t){await a.add(c);t=await a.match(c);if(t&&!t.ok){t=undefined;void a.delete(c)}}}catch(e){console.warn("Slick: ",e)}}const c=document.createElement("script");if(t){c.type="application/javascript";c.appendChild(document.createTextNode(await t.text()))}else{c.src=e}(document.head||document.body).appendChild(c);return c};n(new URL(`${t}?site=${c}`,e).href)})
(
  "https://app.slickstream.com",
  "https://app.slickstream.com/e3/embed.js",
  "K6TYP1DQ",
);</script> <meta property="slick:group" content="post" /><meta property="slick:category" content="main-dishes:Main Dishes;recipes:Recipes" /><meta property="slick:category" content="pork:Pork;recipes:Recipes" /><meta property="slick:category" content="recipes:Recipes" /><meta property="slick:wppostid" content="39997" /><meta property="slick:featured_image" content="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17.jpg" /><style type="text/css" data-source="Grow by Mediavine"></style><style type="text/css">.wprm-comment-rating svg path, .comment-form-wprm-rating svg path { fill: #fecd00; } .comment-form-wprm-rating .wprm-rating-star.rated svg polygon { fill: #fecd00; } .wprm-comment-rating svg polygon, .comment-form-wprm-rating svg polygon { stroke: #fecd00; }</style><meta http-equiv="Content-Security-Policy" content="upgrade-insecure-requests;block-all-mixed-content" /><link rel="icon" href="https://thewoksoflife.com/wp-content/uploads/2014/10/TWOL-Bowl-Favicon.ico" /><link rel="pingback" href="https://thewoksoflife.com/xmlrpc.php" /><meta name="p:domain_verify" content="30015a499feadb9c68198258b4c3e2f2" /><meta name="msvalidate.01" content="32AAE00E89F95B57DF9331F382CB26C1" /><meta name="google-site-verification" content="mxGNTKW0K6l_thaJwLiadsZ-IzB7SNeGQyc46TmqxsI" /><link rel="icon" href="https://thewoksoflife.com/wp-content/uploads/2014/10/TWOL-Bowl-Favicon.ico" type="image/x-icon" /><link rel="shortcut icon" href="https://thewoksoflife.com/wp-content/uploads/2014/10/TWOL-Bowl-Favicon.ico" type="image/x-icon" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-41678252-1', 'thewoksoflife.com');
  ga('require', 'displayfeatures');
  ga('require', 'linkid', 'linkid.js');
  ga('send', 'pageview');</script> <style>.nc_socialPanel .sw, .nc_socialPanel span.swp_count, span.swp_share {
color: #fff!important;
}</style><style>#related_posts_thumbnails li{
          border-right: 1px solid #ffffff;
          background-color: #FFFFFF      }
      #related_posts_thumbnails li:hover{
          background-color: #ffffff;
      }
      .relpost_content{
          font-size: 12px;
          color: #333333;
      }
      .relpost-block-single{
          background-color: #FFFFFF;
          border-right: 1px solid  #ffffff;
          border-left: 1px solid  #ffffff;
          margin-right: -1px;
      }
      .relpost-block-single:hover{
          background-color: #ffffff;
      }</style><style type="text/css">html body div.easyrecipe .ERSName { font-family: Lato!important;font-weight: bold!important;font-size: 30px!important;margin-bottom: 0px!important;margin-left: 0px!important;margin-right: 0px!important;padding-bottom: 0px!important;padding-left: 0px!important;padding-right: 0px!important; }
body.gppro-custom .content>.entry .entry-content a.ERSPrintBtn {
color: #fff;
}</style><style type="text/css" id="wp-custom-css">body.gppro-custom .content>.entry .entry-content .swp_social_panel.swp_default_full_color a {
    color: #fff;
}

body.gppro-custom .content>.entry .entry-content .swp_social_panel.swp_default_full_color a:hover, body.gppro-custom .content>.entry .entry-content span.swp_share {
    color: #000!important  ;
}

body.gppro-custom .entry-header .entry-meta .entry-modified-time {
	color: #dd0b0b;
}	

.nav-primary .genesis-nav-menu .search input[type=submit] {
	text-indent: -9999px;
	top: 0;	
}
.wp-caption {
	max-width: 600px!important;
	width: 100%!important;
}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head><body data-rsssl=1 class="post-template-default single single-post postid-39997 single-format-standard header-full-width content-sidebar genesis-breadcrumbs-visible genesis-footer-widgets-visible gppro-custom"><div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://thewoksoflife.com/">The Woks of Life</a></p><p class="site-description">a culinary genealogy</p></div></div></header><div class="surprise-me-mobile"><a href="/?redirect_to=random">Surprise Me!</a></div><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-608"><a href="https://thewoksoflife.com"><span>HOME</span></a></li><li id="menu-item-23" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23"><a href="https://thewoksoflife.com/about/"><span>About</span></a></li><li id="menu-item-3080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-3080"><a><span>RECIPES</span></a><ul class="sub-menu"><li id="menu-item-8819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8819"><a href="https://thewoksoflife.com/visual-recipe-index/"><span>Visual Recipe Index</span></a></li><li id="menu-item-2605" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2605"><a href="https://thewoksoflife.com/recipe-list/"><span>Recipe List</span></a><ul class="sub-menu"><li id="menu-item-12820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12820"><a href="https://thewoksoflife.com/recipe-list/"><span>Complete Recipe List</span></a></li><li id="menu-item-19555" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19555"><a href="https://thewoksoflife.com/holiday-season-recipes/"><span>Holiday Season Recipes</span></a></li><li id="menu-item-12837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12837"><a href="https://thewoksoflife.com/chinese-new-year-recipes/"><span>Chinese New Year</span></a></li><li id="menu-item-12809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12809"><a href="https://thewoksoflife.com/chinese-take-out-recipes/"><span>Chinese Take Out</span></a></li><li id="menu-item-12806" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12806"><a href="https://thewoksoflife.com/chinese-dim-sum-recipes/"><span>Chinese Dim Sum</span></a></li><li id="menu-item-12807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12807"><a href="https://thewoksoflife.com/quick-easy-recipes/"><span>Quick and Easy</span></a></li><li id="menu-item-12808" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12808"><a href="https://thewoksoflife.com/chinese-bakery-recipes/"><span>Chinese Bakery</span></a></li><li id="menu-item-12805" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12805"><a href="https://thewoksoflife.com/chinese-vegetarian-recipes/"><span>Vegetarian</span></a></li></ul></li></ul></li><li id="menu-item-11217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11217"><a href="https://thewoksoflife.com/chinese-ingredients-glossary/"><span>Ingredients</span></a></li><li id="menu-item-7902" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7902"><a href="https://thewoksoflife.com/category/how-to/"><span>How-To</span></a><ul class="sub-menu"><li id="menu-item-39556" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39556"><a href="https://thewoksoflife.com/category/how-to/cooking-methods/"><span>Cooking Methods</span></a></li><li id="menu-item-39557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39557"><a href="https://thewoksoflife.com/category/how-to/cooking-tools/"><span>Cooking Tools</span></a></li><li id="menu-item-39552" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39552"><a href="https://thewoksoflife.com/category/how-to/chinese-culture/"><span>Culture</span></a></li></ul></li><li id="menu-item-7662" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7662"><a href="https://thewoksoflife.com/category/life/"><span>LIFE</span></a></li><li id="menu-item-7661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7661"><a href="https://thewoksoflife.com/category/travel/"><span>TRAVEL</span></a></li><li id="menu-item-137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-137"><a href="https://thewoksoflife.com/contact/"><span>Contact</span></a><ul class="sub-menu"><li id="menu-item-14688" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14688"><a href="https://thewoksoflife.com/work-with-us/"><span>Work with Us</span></a></li><li id="menu-item-14689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14689"><a href="https://thewoksoflife.com/press/"><span>Press</span></a></li></ul></li><li id="menu-item-39565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39565"><a href="/?redirect_to=random"><span>Surprise Me!</span></a></li><li class="right search"><form class="search-form" method="get" action="https://thewoksoflife.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="SEARCH HERE &#x2026;"><input class="search-form-submit" type="submit"><meta content="https://thewoksoflife.com/?s={s}"></form></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb"><span><span><a href="https://thewoksoflife.com/">Home</a> » <span><a href="https://thewoksoflife.com/category/recipes/">Recipes</a> » <strong class="breadcrumb_last" aria-current="page">Pork Ribs with Black Bean Sauce</strong></span></span></span></div><article class="post-39997 post type-post status-publish format-standard has-post-thumbnail category-main-dishes category-pork category-recipes entry"><header class="entry-header"><h1 class="entry-title">Pork Ribs with Black Bean Sauce</h1><p class="entry-meta">Published: <time class="entry-time">June 1, 2020</time> Last Updated: <time class="entry-modified-time">June 1, 2020</time><br />By <span class="entry-author"><a href="https://thewoksoflife.com/author/bleung/" class="entry-author-link" rel="author"><span class="entry-author-name">Bill</span></a></span> <span class="entry-comments-link"><a href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comments">9 Comments</a></span></p></header><a href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/" title="Pork Ribs with Black Bean Sauce"><img width="650" height="849" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20849'%3E%3C/svg%3E" class="post-image" alt="Chinese Ribs with Black Bean Sauce, thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17.jpg" /><noscript><img width="650" height="849" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17.jpg" class="post-image" alt="Chinese Ribs with Black Bean Sauce, thewoksoflife.com" /></noscript></a><div class="entry-content"><div id="dpsp-content-top" class="dpsp-content-wrapper dpsp-shape-circle dpsp-size-small dpsp-has-spacing dpsp-show-on-mobile dpsp-button-style-6"><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content dpsp-networks-btns-share dpsp-column-auto "><li><a rel="nofollow noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthewoksoflife.com%2Fpork-ribs-black-bean-sauce%2F&t=Pork%20Ribs%20with%20Black%20Bean%20Sauce" class="dpsp-network-btn dpsp-facebook dpsp-first" target="_blank" title="Share on Facebook"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="18" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="18" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Share</span></span></a></li><li><a rel="nofollow noopener noreferrer" data-href="#" class="dpsp-network-btn dpsp-pinterest" target="_blank" title="Save to Pinterest"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="23" height="32" viewBox="0 0 23 32"><path d="M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="23" height="32" viewBox="0 0 23 32"><path d="M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Pin</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="https://www.yummly.com/urb/verify?url=https%3A%2F%2Fthewoksoflife.com%2Fpork-ribs-black-bean-sauce%2F&title=Pork%20Ribs%20with%20Black%20Bean%20Sauce&image=https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17.jpg" class="dpsp-network-btn dpsp-yummly" target="_blank" title="Share on Yummly"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="49" height="32" viewBox="0 0 49 32"><path d="M4.576 0.128c-0.032 0.032-0.16 0.064-0.32 0.064-0.576 0.096-1.216 0.288-1.376 0.384-0.064 0.064-0.128 0.064-0.16 0.032s-0.032 0-0.032 0.064c0 0.064-0.032 0.064-0.064 0.064-0.096-0.096-1.504 0.672-1.888 1.024-0.16 0.16-0.32 0.288-0.32 0.256s-0.096 0.096-0.192 0.288c-0.16 0.256-0.192 0.416-0.192 0.672 0.032 0.224 0.096 0.448 0.16 0.512 0.032 0.064 0.064 0.096 0.032 0.096-0.096 0 0.064 0.288 0.384 0.768 0.16 0.224 0.32 0.416 0.384 0.416 0.032 0 0.096 0.032 0.064 0.064-0.032 0.128 0.384 0.416 0.576 0.416 0.128 0 0.32-0.128 0.544-0.32 0.16-0.192 0.352-0.32 0.352-0.32 0.032 0 0.192-0.096 0.384-0.224 0.704-0.48 1.6-0.608 1.856-0.288 0.064 0.064 0.16 0.128 0.192 0.096 0.064-0.032 0.064-0.032 0.032 0.032s-0.032 0.192 0 0.288c0.032 0.096 0.032 0.352 0 0.576-0.032 0.192-0.096 0.48-0.096 0.576-0.032 0.128-0.096 0.384-0.16 0.544-0.032 0.192-0.096 0.384-0.096 0.448-0.032 0.032-0.096 0.288-0.16 0.544-0.096 0.256-0.16 0.576-0.192 0.704s-0.064 0.256-0.064 0.288c-0.064 0.064-0.128 0.352-0.16 0.672-0.032 0.064-0.064 0.16-0.064 0.256-0.064 0.16-0.256 0.832-0.288 0.992 0 0.064-0.032 0.192-0.064 0.256-0.064 0.128-0.224 0.8-0.256 0.992-0.032 0.064-0.16 0.576-0.288 1.088-0.16 0.512-0.288 1.024-0.288 1.088-0.032 0.096-0.096 0.288-0.128 0.448-0.064 0.192-0.064 0.352-0.064 0.384 0.032 0.032 0.032 0.096-0.032 0.096-0.096 0.032-0.224 0.96-0.192 1.632 0 0.544 0.32 1.696 0.448 1.696 0.032 0 0.096 0.064 0.128 0.16 0.064 0.224 0.64 0.768 1.024 0.992 0.96 0.544 2.752 0.608 4.512 0.224 0.736-0.16 1.888-0.544 1.92-0.64 0-0.032 0.064-0.064 0.096-0.032 0.064 0.064 1.088-0.448 1.312-0.64 0.064-0.032 0.128-0.064 0.16-0.032 0.032 0-0.032 0.416-0.128 0.864-0.096 0.48-0.16 0.896-0.16 0.928 0 0.064-0.032 0.224-0.16 0.672 0 0.096-0.096 0.16-0.16 0.16-0.576 0-2.688 0.512-2.688 0.608 0 0.064-0.032 0.064-0.096 0.032s-1.184 0.384-1.28 0.512c-0.032 0.032-0.064 0.064-0.064 0s-0.672 0.288-0.768 0.384c0 0.032-0.064 0.096-0.096 0.096-0.16 0-0.704 0.352-0.672 0.416s0.032 0.064-0.032 0.032c-0.16-0.096-1.856 1.664-1.696 1.824 0.032 0.032 0 0.032-0.064 0.032-0.128 0-0.832 1.472-0.96 2.112-0.032 0.096-0.128 0.992-0.16 1.216-0.032 0.544 0.128 1.344 0.384 1.92 0.864 1.824 3.040 2.688 5.44 2.176 0.512-0.128 1.568-0.512 1.696-0.64 0.064-0.064 0.16-0.128 0.16-0.096 0.064 0.032 0.192 0 0.32-0.128 0.096-0.096 0.256-0.224 0.352-0.288 0.192-0.128 0.736-0.64 1.088-1.024 0.32-0.352 0.768-1.024 0.736-1.088-0.032-0.032-0.032-0.064 0.032-0.064s0.352-0.512 0.352-0.608c0-0.032 0.032-0.096 0.064-0.128 0.192-0.128 0.832-1.888 1.088-3.008 0.16-0.64 0.32-1.184 0.352-1.248 0.064-0.16 0.384-0.16 1.984 0.032 0.992 0.128 1.152 0.128 1.344 0.16 0.128 0.032 0.544 0.096 0.96 0.192 1.12 0.16 0.992 0.16 2.88 0.544 0.736 0.128 1.376 0.256 1.472 0.288 0.064 0 0.192 0.032 0.288 0.064 0.064 0.032 0.224 0.064 0.352 0.064 0.192 0.032 0.832 0.16 0.896 0.192 0.032 0 0.16 0.032 0.256 0.064 0.224 0.064 2.432 0.512 2.752 0.608 0.128 0 0.512 0.096 0.864 0.16 0.8 0.16 1.12 0.224 1.376 0.256 0.096 0 0.192 0.032 0.192 0.032 0 0.032 0.064 0.064 0.096 0.064 0.128 0 0.768 0.096 1.024 0.16 0.704 0.128 2.144 0.352 2.528 0.416 0.288 0.032 0.512 0.064 0.544 0.096 0.032 0 0.32 0.032 0.672 0.064 0.32 0.032 0.672 0.064 0.768 0.096 0.704 0.128 5.152 0.224 5.984 0.096 0.224-0.032 0.608-0.064 0.896-0.096s0.544-0.128 0.576-0.16c0.032-0.032 0.064-0.032 0.096-0.032 0.256 0.16 3.616-0.992 3.616-1.216 0-0.032 0.032-0.064 0.064-0.064 0.096 0.032 0.576-0.224 1.024-0.544 0.512-0.384 0.768-0.896 0.768-1.504 0-0.544-0.288-1.248-0.672-1.76-0.288-0.416-0.608-0.736-0.608-0.64 0 0.032-0.032 0-0.096-0.032-0.064-0.064-0.352 0.032-1.056 0.384-0.544 0.256-1.12 0.512-1.28 0.576s-0.416 0.16-0.544 0.224c-0.32 0.16-2.336 0.672-2.816 0.736-0.192 0.032-0.448 0.064-0.544 0.096-0.128 0-0.448 0.032-0.768 0.064-0.288 0.064-0.672 0.096-0.832 0.096-0.448 0.064-3.904 0.064-4.512 0-0.288 0-0.768-0.064-1.056-0.096-0.416-0.032-0.768-0.064-1.664-0.16-0.128 0-0.384-0.032-0.576-0.064-1.152-0.16-1.792-0.256-1.952-0.256-0.128-0.032-0.224-0.032-0.224-0.032 0-0.032-0.16-0.064-0.704-0.128-0.224-0.032-0.48-0.064-0.576-0.096-0.128-0.032-0.448-0.096-0.768-0.128-0.288-0.064-0.64-0.128-0.736-0.128-0.128-0.032-0.32-0.064-0.416-0.064-0.256-0.064-2.048-0.384-2.368-0.448-0.192-0.032-0.736-0.128-1.024-0.16-0.096 0-0.16-0.032-0.16-0.032 0-0.032-0.224-0.064-0.672-0.128-0.192 0-0.416-0.064-0.512-0.064-0.096-0.032-0.32-0.064-0.544-0.096-0.192-0.032-0.448-0.096-0.544-0.096-0.096-0.032-0.32-0.064-0.512-0.064-0.16-0.032-0.384-0.064-0.48-0.064-0.096-0.032-0.416-0.096-0.672-0.128-0.288-0.032-0.576-0.064-0.672-0.064-0.096-0.032-0.384-0.064-0.64-0.096-0.224-0.032-0.544-0.064-0.704-0.064-0.48-0.064-1.568-0.16-1.76-0.16-0.16 0.032-0.16 0-0.064-0.512 0.064-0.288 0.128-0.672 0.16-0.896 0.128-0.768 0.256-1.6 0.32-1.92 0.032-0.096 0.096-0.352 0.096-0.48 0.032-0.16 0.096-0.512 0.128-0.736 0.064-0.224 0.096-0.544 0.128-0.704 0-0.128 0.064-0.32 0.064-0.416 0.032-0.064 0.064-0.288 0.096-0.512 0.032-0.192 0.064-0.416 0.096-0.48 0-0.064 0.032-0.256 0.064-0.416s0.064-0.384 0.096-0.512c0.032-0.192 0.128-0.704 0.16-1.056 0.032-0.128 0.064-0.352 0.16-0.832 0.032-0.096 0.064-0.32 0.096-0.544 0.032-0.192 0.064-0.448 0.096-0.544 0.032-0.224 0.096-0.544 0.16-0.896 0.032-0.128 0.096-0.576 0.16-0.928 0.064-0.384 0.128-0.8 0.16-0.96s0.096-0.576 0.16-0.896c0.096-0.32 0.16-0.768 0.16-0.96 0.032-0.224 0.064-0.416 0.096-0.48 0.032-0.032 0.064-0.224 0.096-0.448 0-0.192 0.064-0.416 0.064-0.48 0.032-0.064 0.064-0.288 0.096-0.48 0-0.192 0.032-0.384 0.064-0.416 0.096-0.128 0.16-1.152 0.096-1.536-0.032-0.224-0.128-0.48-0.192-0.544-0.096-0.096-0.16-0.192-0.128-0.224 0.032 0-0.128-0.128-0.32-0.224-0.672-0.352-2.176-0.288-2.912 0.128-0.256 0.16-0.288 0.192-0.256 0.512 0.064 0.832 0.032 1.728-0.096 2.496-0.096 0.448-0.16 0.896-0.192 0.96 0 0.064-0.032 0.288-0.064 0.448-0.032 0.192-0.096 0.416-0.096 0.512-0.032 0.096-0.064 0.256-0.064 0.384-0.032 0.096-0.064 0.32-0.096 0.48s-0.128 0.8-0.256 1.376c-0.096 0.608-0.224 1.248-0.224 1.408-0.032 0.16-0.096 0.48-0.16 0.736-0.032 0.256-0.096 0.544-0.128 0.672 0 0.128-0.032 0.352-0.064 0.512s-0.16 0.768-0.256 1.376c-0.128 0.608-0.192 1.152-0.192 1.184 0 0.096-0.768 0.544-1.312 0.736-0.192 0.064-0.384 0.16-0.384 0.224s0 0.064-0.032 0.032-0.352 0.064-0.736 0.192c-1.632 0.544-3.008 0.608-3.488 0.128-0.192-0.192-0.192-0.256-0.192-0.928 0-0.736 0.032-0.896 0.992-4.448 0.064-0.256 0.096-0.512 0.064-0.512 0-0.032 0.032-0.096 0.064-0.096 0.032-0.032 0.096-0.16 0.128-0.288 0-0.128 0.032-0.256 0.032-0.256 0.032 0 0.064-0.128 0.128-0.48 0.096-0.48 0.096-0.512 0.128-0.544 0 0 0.032-0.032 0.032-0.064s0.064-0.224 0.128-0.448c0.064-0.192 0.128-0.448 0.128-0.544s0.032-0.224 0.064-0.288c0.48-1.344 0.48-3.2 0-4.256-0.352-0.8-1.216-1.408-2.208-1.6-0.416-0.064-1.696-0.096-1.76-0.032zM10.944 23.968c-0.032 0.192-0.128 0.416-0.16 0.544s-0.064 0.256-0.064 0.288c0 0.064 0 0.096-0.352 0.96-0.128 0.288-0.224 0.576-0.192 0.576 0.032 0.032 0 0.064-0.064 0.064s-0.224 0.32-0.192 0.448c0 0.032 0 0.032-0.032 0.032-0.064-0.032-0.16 0.064-0.224 0.224-0.192 0.288-0.608 0.704-0.832 0.768-0.064 0.032-0.128 0.064-0.128 0.096 0 0.096-0.064 0.096-0.704 0.128-0.544 0.032-0.736-0.064-0.96-0.512-0.16-0.224-0.128-0.992 0.032-1.408 0.064-0.16 0.128-0.352 0.128-0.416s0.032-0.096 0.064-0.064c0.064 0.032 0.096-0.032 0.128-0.128 0.064-0.192 0.832-0.928 0.992-0.928 0.032 0 0.032-0.032 0-0.064-0.032-0.064 0-0.096 0.032-0.096 0.096 0.064 0.704-0.256 0.8-0.384 0.032-0.032 0.064-0.032 0.064 0s0.064 0 0.16-0.032c0.16-0.096 1.28-0.416 1.472-0.416 0.064 0 0.064 0.096 0.032 0.32zM38.848 5.952c-0.16 0.032-0.384 0.064-0.512 0.096-0.288 0.064-1.44 0.48-1.504 0.576-0.032 0.064-0.064 0.064-0.064 0.032s-0.16 0.032-0.352 0.096c-0.32 0.192-0.576 0.224-0.544 0.128 0-0.128-0.128-0.352-0.256-0.352-0.064 0-0.096-0.032-0.096-0.064 0-0.16-0.608-0.352-1.312-0.384-0.48-0.064-2.048 0.384-1.92 0.512 0.032 0 0 0.096-0.032 0.128-0.064 0.096-0.064 0.224 0 0.448 0.096 0.416 0.096 1.248 0 1.632-0.064 0.16-0.096 0.416-0.128 0.64s-0.032 0.384-0.032 0.384c-0.032 0-0.064 0.16-0.128 0.576-0.032 0.16-0.064 0.384-0.096 0.48-0.032 0.128-0.064 0.32-0.064 0.48-0.032 0.16-0.064 0.384-0.096 0.512-0.064 0.224-0.448 2.496-0.512 2.816-0.032 0.256-0.096 0.576-0.192 1.184-0.064 0.256-0.128 0.608-0.128 0.768-0.032 0.128-0.064 0.384-0.096 0.48-0.288 1.6 0.032 2.368 1.056 2.592 0.48 0.128 1.728 0.032 1.888-0.096 0.032-0.032 0.128-0.064 0.224-0.064 0.064 0 0.128-0.032 0.128-0.096 0-0.032 0.032-0.064 0.064-0.064 0.352 0.064 0.448-0.224 0.32-0.8-0.128-0.544-0.096-0.896 0.096-1.856 0.064-0.416 0.16-0.864 0.16-0.992 0.032-0.128 0.064-0.352 0.096-0.448 0.096-0.544 0.128-0.64 0.16-0.896 0.032-0.128 0.064-0.352 0.064-0.48 0.032-0.16 0.064-0.384 0.096-0.512 0.224-1.152 0.288-1.568 0.256-1.632-0.032-0.032-0.032-0.096 0.032-0.128 0.032 0 0.064-0.128 0.064-0.256s0.064-0.48 0.128-0.736l0.096-0.512 0.576-0.256c0.64-0.32 0.992-0.416 1.44-0.32 0.544 0.096 0.704 0.704 0.512 1.824-0.032 0.192-0.096 0.416-0.096 0.512-0.032 0.096-0.064 0.256-0.064 0.384-0.032 0.096-0.064 0.32-0.096 0.48s-0.096 0.608-0.16 1.024c-0.064 0.384-0.16 0.832-0.16 1.024-0.032 0.16-0.064 0.32-0.096 0.384-0.032 0.032-0.064 0.224-0.096 0.48 0 0.224-0.064 0.48-0.096 0.608-0.224 1.152-0.288 2.112-0.16 2.56 0.128 0.32 0.608 0.8 0.736 0.768 0.064-0.032 0.192 0 0.32 0.064 0.256 0.16 1.376 0.096 1.984-0.096 0.576-0.16 0.8-0.384 0.736-0.672-0.032-0.128-0.096-0.32-0.096-0.448-0.032-0.128-0.064-0.256-0.064-0.288-0.032-0.064 0.032-0.512 0.128-1.024 0.064-0.512 0.16-1.056 0.192-1.216s0.096-0.448 0.128-0.704c0.096-0.448 0.16-0.896 0.192-1.152 0.032-0.096 0.096-0.544 0.16-0.96 0.096-0.448 0.16-0.896 0.192-0.992 0-0.128 0.064-0.352 0.064-0.512 0.032-0.16 0.128-0.544 0.16-0.864l0.096-0.576 0.544-0.288c0.768-0.384 1.344-0.48 1.664-0.288 0.16 0.096 0.32 0.288 0.352 0.416 0.096 0.256 0.032 1.088-0.128 1.984-0.064 0.288-0.096 0.448-0.288 1.664-0.224 1.312-0.256 1.472-0.32 1.792 0 0.16-0.032 0.352-0.064 0.416 0 0.064-0.064 0.256-0.064 0.384-0.032 0.16-0.096 0.416-0.096 0.544-0.224 1.216-0.224 1.76 0 2.24 0.128 0.224 0.288 0.352 0.576 0.512 0.384 0.192 0.512 0.192 1.216 0.192 0.608 0 0.896-0.032 1.28-0.192 0.608-0.224 0.672-0.352 0.544-0.928-0.096-0.512-0.032-1.408 0.192-2.464 0.032-0.224 0.096-0.576 0.128-0.736 0.032-0.192 0.096-0.608 0.16-0.928 0.064-0.288 0.096-0.576 0.096-0.608s0-0.064 0.032-0.096c0.032-0.096 0.064-0.288 0.096-0.672 0.032-0.224 0.096-0.448 0.096-0.512 0.032-0.064 0.064-0.256 0.096-0.416 0-0.16 0.064-0.384 0.064-0.448 0.032-0.128 0.064-0.32 0.096-0.48s0.064-0.352 0.064-0.448c0.224-1.088 0.32-2.272 0.192-2.848-0.096-0.512-0.128-0.576-0.256-0.832-0.416-0.8-1.12-1.184-2.432-1.248-0.608-0.032-2.464 0.448-2.464 0.64 0 0.064 0 0.064-0.032 0.032s-0.384 0.128-0.736 0.32l-0.704 0.352-0.16-0.224c-0.224-0.416-0.608-0.736-1.088-0.896-0.48-0.192-1.504-0.288-1.952-0.16zM21.536 6.048c0 0.032-0.224 0.064-0.48 0.064-0.544 0.064-1.184 0.224-1.184 0.352 0 0.032-0.032 0.032-0.064 0.032-0.032-0.032-0.128 0-0.224 0.096-0.128 0.16-0.128 0.192 0.032 0.832 0.064 0.224 0.032 0.864-0.064 1.376-0.064 0.288-0.128 0.608-0.128 0.768 0 0.128-0.064 0.416-0.128 0.64-0.032 0.224-0.096 0.544-0.128 0.704-0.064 0.544-0.096 0.704-0.16 0.864 0 0.064-0.064 0.32-0.064 0.544-0.032 0.224-0.064 0.416-0.096 0.448 0 0.032-0.064 0.224-0.096 0.48-0.032 0.224-0.064 0.48-0.064 0.544-0.032 0.064-0.064 0.256-0.096 0.416-0.096 0.544-0.128 0.8-0.16 1.024-0.16 0.896-0.096 2.208 0.096 2.624 0.064 0.096 0.128 0.256 0.192 0.384 0.16 0.352 0.704 0.896 1.056 1.024 0.928 0.384 1.664 0.416 2.784 0.128 0.224-0.064 0.416-0.128 0.448-0.128 0.064 0 0.16-0.064 0.256-0.096 0.704-0.288 1.472-0.544 1.504-0.512 0 0 0.064 0.128 0.128 0.256 0.288 0.608 0.896 0.864 1.888 0.864 0.64-0.032 1.536-0.256 1.632-0.416 0.032-0.032 0.096-0.064 0.128-0.096 0.032 0 0.064-0.16 0.064-0.384-0.096-1.248-0.096-1.472-0.032-1.76 0.032-0.16 0.096-0.416 0.128-0.576 0.064-0.576 0.128-0.96 0.16-1.12 0.032-0.096 0.064-0.288 0.096-0.448s0.064-0.384 0.096-0.48c0-0.096 0.032-0.288 0.064-0.448s0.096-0.576 0.16-0.896c0.064-0.288 0.128-0.576 0.096-0.608s0-0.096 0.032-0.16c0.032-0.096 0.096-0.32 0.128-0.512 0.032-0.224 0.064-0.48 0.096-0.608 0.032-0.192 0.32-1.792 0.416-2.272 0-0.16 0.064-0.352 0.064-0.48 0.128-0.448 0.064-1.312-0.096-1.632-0.128-0.288-0.736-0.768-0.832-0.672-0.032 0.032-0.096 0-0.16-0.032-0.096-0.096-1.088-0.128-1.44-0.032-0.448 0.096-1.056 0.32-1.184 0.416-0.096 0.096-0.096 0.192-0.032 0.544 0.096 0.448 0.096 1.312 0 1.824-0.032 0.16-0.128 0.576-0.192 0.928-0.064 0.32-0.096 0.64-0.096 0.64 0 0.032 0 0.096 0 0.128-0.032 0.064-0.096 0.352-0.128 0.576-0.032 0.192-0.128 0.704-0.192 1.024-0.032 0.096-0.064 0.32-0.064 0.48-0.032 0.16-0.064 0.32-0.064 0.384-0.032 0.032-0.064 0.256-0.096 0.48-0.064 0.224-0.096 0.448-0.096 0.48 0 0-0.064 0.32-0.128 0.704-0.096 0.576-0.128 0.64-0.352 0.736-0.128 0.064-0.224 0.128-0.192 0.128 0.032 0.032-0.032 0.064-0.096 0.064-0.096 0-0.32 0.064-0.512 0.16-0.864 0.32-1.856 0.064-1.92-0.512 0-0.096-0.032-0.224-0.032-0.288 0-0.16 0.16-1.472 0.192-1.472 0 0 0.032-0.064 0.032-0.16s0.032-0.288 0.064-0.416c0.032-0.128 0.096-0.384 0.096-0.512 0.128-0.704 0.192-1.152 0.256-1.44 0.032-0.128 0.064-0.384 0.096-0.544 0.032-0.192 0.128-0.8 0.256-1.344 0.288-1.632 0.16-2.432-0.416-2.784-0.16-0.064-0.288-0.16-0.352-0.16-0.512-0.096-0.864-0.16-0.896-0.16z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="49" height="32" viewBox="0 0 49 32"><path d="M4.576 0.128c-0.032 0.032-0.16 0.064-0.32 0.064-0.576 0.096-1.216 0.288-1.376 0.384-0.064 0.064-0.128 0.064-0.16 0.032s-0.032 0-0.032 0.064c0 0.064-0.032 0.064-0.064 0.064-0.096-0.096-1.504 0.672-1.888 1.024-0.16 0.16-0.32 0.288-0.32 0.256s-0.096 0.096-0.192 0.288c-0.16 0.256-0.192 0.416-0.192 0.672 0.032 0.224 0.096 0.448 0.16 0.512 0.032 0.064 0.064 0.096 0.032 0.096-0.096 0 0.064 0.288 0.384 0.768 0.16 0.224 0.32 0.416 0.384 0.416 0.032 0 0.096 0.032 0.064 0.064-0.032 0.128 0.384 0.416 0.576 0.416 0.128 0 0.32-0.128 0.544-0.32 0.16-0.192 0.352-0.32 0.352-0.32 0.032 0 0.192-0.096 0.384-0.224 0.704-0.48 1.6-0.608 1.856-0.288 0.064 0.064 0.16 0.128 0.192 0.096 0.064-0.032 0.064-0.032 0.032 0.032s-0.032 0.192 0 0.288c0.032 0.096 0.032 0.352 0 0.576-0.032 0.192-0.096 0.48-0.096 0.576-0.032 0.128-0.096 0.384-0.16 0.544-0.032 0.192-0.096 0.384-0.096 0.448-0.032 0.032-0.096 0.288-0.16 0.544-0.096 0.256-0.16 0.576-0.192 0.704s-0.064 0.256-0.064 0.288c-0.064 0.064-0.128 0.352-0.16 0.672-0.032 0.064-0.064 0.16-0.064 0.256-0.064 0.16-0.256 0.832-0.288 0.992 0 0.064-0.032 0.192-0.064 0.256-0.064 0.128-0.224 0.8-0.256 0.992-0.032 0.064-0.16 0.576-0.288 1.088-0.16 0.512-0.288 1.024-0.288 1.088-0.032 0.096-0.096 0.288-0.128 0.448-0.064 0.192-0.064 0.352-0.064 0.384 0.032 0.032 0.032 0.096-0.032 0.096-0.096 0.032-0.224 0.96-0.192 1.632 0 0.544 0.32 1.696 0.448 1.696 0.032 0 0.096 0.064 0.128 0.16 0.064 0.224 0.64 0.768 1.024 0.992 0.96 0.544 2.752 0.608 4.512 0.224 0.736-0.16 1.888-0.544 1.92-0.64 0-0.032 0.064-0.064 0.096-0.032 0.064 0.064 1.088-0.448 1.312-0.64 0.064-0.032 0.128-0.064 0.16-0.032 0.032 0-0.032 0.416-0.128 0.864-0.096 0.48-0.16 0.896-0.16 0.928 0 0.064-0.032 0.224-0.16 0.672 0 0.096-0.096 0.16-0.16 0.16-0.576 0-2.688 0.512-2.688 0.608 0 0.064-0.032 0.064-0.096 0.032s-1.184 0.384-1.28 0.512c-0.032 0.032-0.064 0.064-0.064 0s-0.672 0.288-0.768 0.384c0 0.032-0.064 0.096-0.096 0.096-0.16 0-0.704 0.352-0.672 0.416s0.032 0.064-0.032 0.032c-0.16-0.096-1.856 1.664-1.696 1.824 0.032 0.032 0 0.032-0.064 0.032-0.128 0-0.832 1.472-0.96 2.112-0.032 0.096-0.128 0.992-0.16 1.216-0.032 0.544 0.128 1.344 0.384 1.92 0.864 1.824 3.040 2.688 5.44 2.176 0.512-0.128 1.568-0.512 1.696-0.64 0.064-0.064 0.16-0.128 0.16-0.096 0.064 0.032 0.192 0 0.32-0.128 0.096-0.096 0.256-0.224 0.352-0.288 0.192-0.128 0.736-0.64 1.088-1.024 0.32-0.352 0.768-1.024 0.736-1.088-0.032-0.032-0.032-0.064 0.032-0.064s0.352-0.512 0.352-0.608c0-0.032 0.032-0.096 0.064-0.128 0.192-0.128 0.832-1.888 1.088-3.008 0.16-0.64 0.32-1.184 0.352-1.248 0.064-0.16 0.384-0.16 1.984 0.032 0.992 0.128 1.152 0.128 1.344 0.16 0.128 0.032 0.544 0.096 0.96 0.192 1.12 0.16 0.992 0.16 2.88 0.544 0.736 0.128 1.376 0.256 1.472 0.288 0.064 0 0.192 0.032 0.288 0.064 0.064 0.032 0.224 0.064 0.352 0.064 0.192 0.032 0.832 0.16 0.896 0.192 0.032 0 0.16 0.032 0.256 0.064 0.224 0.064 2.432 0.512 2.752 0.608 0.128 0 0.512 0.096 0.864 0.16 0.8 0.16 1.12 0.224 1.376 0.256 0.096 0 0.192 0.032 0.192 0.032 0 0.032 0.064 0.064 0.096 0.064 0.128 0 0.768 0.096 1.024 0.16 0.704 0.128 2.144 0.352 2.528 0.416 0.288 0.032 0.512 0.064 0.544 0.096 0.032 0 0.32 0.032 0.672 0.064 0.32 0.032 0.672 0.064 0.768 0.096 0.704 0.128 5.152 0.224 5.984 0.096 0.224-0.032 0.608-0.064 0.896-0.096s0.544-0.128 0.576-0.16c0.032-0.032 0.064-0.032 0.096-0.032 0.256 0.16 3.616-0.992 3.616-1.216 0-0.032 0.032-0.064 0.064-0.064 0.096 0.032 0.576-0.224 1.024-0.544 0.512-0.384 0.768-0.896 0.768-1.504 0-0.544-0.288-1.248-0.672-1.76-0.288-0.416-0.608-0.736-0.608-0.64 0 0.032-0.032 0-0.096-0.032-0.064-0.064-0.352 0.032-1.056 0.384-0.544 0.256-1.12 0.512-1.28 0.576s-0.416 0.16-0.544 0.224c-0.32 0.16-2.336 0.672-2.816 0.736-0.192 0.032-0.448 0.064-0.544 0.096-0.128 0-0.448 0.032-0.768 0.064-0.288 0.064-0.672 0.096-0.832 0.096-0.448 0.064-3.904 0.064-4.512 0-0.288 0-0.768-0.064-1.056-0.096-0.416-0.032-0.768-0.064-1.664-0.16-0.128 0-0.384-0.032-0.576-0.064-1.152-0.16-1.792-0.256-1.952-0.256-0.128-0.032-0.224-0.032-0.224-0.032 0-0.032-0.16-0.064-0.704-0.128-0.224-0.032-0.48-0.064-0.576-0.096-0.128-0.032-0.448-0.096-0.768-0.128-0.288-0.064-0.64-0.128-0.736-0.128-0.128-0.032-0.32-0.064-0.416-0.064-0.256-0.064-2.048-0.384-2.368-0.448-0.192-0.032-0.736-0.128-1.024-0.16-0.096 0-0.16-0.032-0.16-0.032 0-0.032-0.224-0.064-0.672-0.128-0.192 0-0.416-0.064-0.512-0.064-0.096-0.032-0.32-0.064-0.544-0.096-0.192-0.032-0.448-0.096-0.544-0.096-0.096-0.032-0.32-0.064-0.512-0.064-0.16-0.032-0.384-0.064-0.48-0.064-0.096-0.032-0.416-0.096-0.672-0.128-0.288-0.032-0.576-0.064-0.672-0.064-0.096-0.032-0.384-0.064-0.64-0.096-0.224-0.032-0.544-0.064-0.704-0.064-0.48-0.064-1.568-0.16-1.76-0.16-0.16 0.032-0.16 0-0.064-0.512 0.064-0.288 0.128-0.672 0.16-0.896 0.128-0.768 0.256-1.6 0.32-1.92 0.032-0.096 0.096-0.352 0.096-0.48 0.032-0.16 0.096-0.512 0.128-0.736 0.064-0.224 0.096-0.544 0.128-0.704 0-0.128 0.064-0.32 0.064-0.416 0.032-0.064 0.064-0.288 0.096-0.512 0.032-0.192 0.064-0.416 0.096-0.48 0-0.064 0.032-0.256 0.064-0.416s0.064-0.384 0.096-0.512c0.032-0.192 0.128-0.704 0.16-1.056 0.032-0.128 0.064-0.352 0.16-0.832 0.032-0.096 0.064-0.32 0.096-0.544 0.032-0.192 0.064-0.448 0.096-0.544 0.032-0.224 0.096-0.544 0.16-0.896 0.032-0.128 0.096-0.576 0.16-0.928 0.064-0.384 0.128-0.8 0.16-0.96s0.096-0.576 0.16-0.896c0.096-0.32 0.16-0.768 0.16-0.96 0.032-0.224 0.064-0.416 0.096-0.48 0.032-0.032 0.064-0.224 0.096-0.448 0-0.192 0.064-0.416 0.064-0.48 0.032-0.064 0.064-0.288 0.096-0.48 0-0.192 0.032-0.384 0.064-0.416 0.096-0.128 0.16-1.152 0.096-1.536-0.032-0.224-0.128-0.48-0.192-0.544-0.096-0.096-0.16-0.192-0.128-0.224 0.032 0-0.128-0.128-0.32-0.224-0.672-0.352-2.176-0.288-2.912 0.128-0.256 0.16-0.288 0.192-0.256 0.512 0.064 0.832 0.032 1.728-0.096 2.496-0.096 0.448-0.16 0.896-0.192 0.96 0 0.064-0.032 0.288-0.064 0.448-0.032 0.192-0.096 0.416-0.096 0.512-0.032 0.096-0.064 0.256-0.064 0.384-0.032 0.096-0.064 0.32-0.096 0.48s-0.128 0.8-0.256 1.376c-0.096 0.608-0.224 1.248-0.224 1.408-0.032 0.16-0.096 0.48-0.16 0.736-0.032 0.256-0.096 0.544-0.128 0.672 0 0.128-0.032 0.352-0.064 0.512s-0.16 0.768-0.256 1.376c-0.128 0.608-0.192 1.152-0.192 1.184 0 0.096-0.768 0.544-1.312 0.736-0.192 0.064-0.384 0.16-0.384 0.224s0 0.064-0.032 0.032-0.352 0.064-0.736 0.192c-1.632 0.544-3.008 0.608-3.488 0.128-0.192-0.192-0.192-0.256-0.192-0.928 0-0.736 0.032-0.896 0.992-4.448 0.064-0.256 0.096-0.512 0.064-0.512 0-0.032 0.032-0.096 0.064-0.096 0.032-0.032 0.096-0.16 0.128-0.288 0-0.128 0.032-0.256 0.032-0.256 0.032 0 0.064-0.128 0.128-0.48 0.096-0.48 0.096-0.512 0.128-0.544 0 0 0.032-0.032 0.032-0.064s0.064-0.224 0.128-0.448c0.064-0.192 0.128-0.448 0.128-0.544s0.032-0.224 0.064-0.288c0.48-1.344 0.48-3.2 0-4.256-0.352-0.8-1.216-1.408-2.208-1.6-0.416-0.064-1.696-0.096-1.76-0.032zM10.944 23.968c-0.032 0.192-0.128 0.416-0.16 0.544s-0.064 0.256-0.064 0.288c0 0.064 0 0.096-0.352 0.96-0.128 0.288-0.224 0.576-0.192 0.576 0.032 0.032 0 0.064-0.064 0.064s-0.224 0.32-0.192 0.448c0 0.032 0 0.032-0.032 0.032-0.064-0.032-0.16 0.064-0.224 0.224-0.192 0.288-0.608 0.704-0.832 0.768-0.064 0.032-0.128 0.064-0.128 0.096 0 0.096-0.064 0.096-0.704 0.128-0.544 0.032-0.736-0.064-0.96-0.512-0.16-0.224-0.128-0.992 0.032-1.408 0.064-0.16 0.128-0.352 0.128-0.416s0.032-0.096 0.064-0.064c0.064 0.032 0.096-0.032 0.128-0.128 0.064-0.192 0.832-0.928 0.992-0.928 0.032 0 0.032-0.032 0-0.064-0.032-0.064 0-0.096 0.032-0.096 0.096 0.064 0.704-0.256 0.8-0.384 0.032-0.032 0.064-0.032 0.064 0s0.064 0 0.16-0.032c0.16-0.096 1.28-0.416 1.472-0.416 0.064 0 0.064 0.096 0.032 0.32zM38.848 5.952c-0.16 0.032-0.384 0.064-0.512 0.096-0.288 0.064-1.44 0.48-1.504 0.576-0.032 0.064-0.064 0.064-0.064 0.032s-0.16 0.032-0.352 0.096c-0.32 0.192-0.576 0.224-0.544 0.128 0-0.128-0.128-0.352-0.256-0.352-0.064 0-0.096-0.032-0.096-0.064 0-0.16-0.608-0.352-1.312-0.384-0.48-0.064-2.048 0.384-1.92 0.512 0.032 0 0 0.096-0.032 0.128-0.064 0.096-0.064 0.224 0 0.448 0.096 0.416 0.096 1.248 0 1.632-0.064 0.16-0.096 0.416-0.128 0.64s-0.032 0.384-0.032 0.384c-0.032 0-0.064 0.16-0.128 0.576-0.032 0.16-0.064 0.384-0.096 0.48-0.032 0.128-0.064 0.32-0.064 0.48-0.032 0.16-0.064 0.384-0.096 0.512-0.064 0.224-0.448 2.496-0.512 2.816-0.032 0.256-0.096 0.576-0.192 1.184-0.064 0.256-0.128 0.608-0.128 0.768-0.032 0.128-0.064 0.384-0.096 0.48-0.288 1.6 0.032 2.368 1.056 2.592 0.48 0.128 1.728 0.032 1.888-0.096 0.032-0.032 0.128-0.064 0.224-0.064 0.064 0 0.128-0.032 0.128-0.096 0-0.032 0.032-0.064 0.064-0.064 0.352 0.064 0.448-0.224 0.32-0.8-0.128-0.544-0.096-0.896 0.096-1.856 0.064-0.416 0.16-0.864 0.16-0.992 0.032-0.128 0.064-0.352 0.096-0.448 0.096-0.544 0.128-0.64 0.16-0.896 0.032-0.128 0.064-0.352 0.064-0.48 0.032-0.16 0.064-0.384 0.096-0.512 0.224-1.152 0.288-1.568 0.256-1.632-0.032-0.032-0.032-0.096 0.032-0.128 0.032 0 0.064-0.128 0.064-0.256s0.064-0.48 0.128-0.736l0.096-0.512 0.576-0.256c0.64-0.32 0.992-0.416 1.44-0.32 0.544 0.096 0.704 0.704 0.512 1.824-0.032 0.192-0.096 0.416-0.096 0.512-0.032 0.096-0.064 0.256-0.064 0.384-0.032 0.096-0.064 0.32-0.096 0.48s-0.096 0.608-0.16 1.024c-0.064 0.384-0.16 0.832-0.16 1.024-0.032 0.16-0.064 0.32-0.096 0.384-0.032 0.032-0.064 0.224-0.096 0.48 0 0.224-0.064 0.48-0.096 0.608-0.224 1.152-0.288 2.112-0.16 2.56 0.128 0.32 0.608 0.8 0.736 0.768 0.064-0.032 0.192 0 0.32 0.064 0.256 0.16 1.376 0.096 1.984-0.096 0.576-0.16 0.8-0.384 0.736-0.672-0.032-0.128-0.096-0.32-0.096-0.448-0.032-0.128-0.064-0.256-0.064-0.288-0.032-0.064 0.032-0.512 0.128-1.024 0.064-0.512 0.16-1.056 0.192-1.216s0.096-0.448 0.128-0.704c0.096-0.448 0.16-0.896 0.192-1.152 0.032-0.096 0.096-0.544 0.16-0.96 0.096-0.448 0.16-0.896 0.192-0.992 0-0.128 0.064-0.352 0.064-0.512 0.032-0.16 0.128-0.544 0.16-0.864l0.096-0.576 0.544-0.288c0.768-0.384 1.344-0.48 1.664-0.288 0.16 0.096 0.32 0.288 0.352 0.416 0.096 0.256 0.032 1.088-0.128 1.984-0.064 0.288-0.096 0.448-0.288 1.664-0.224 1.312-0.256 1.472-0.32 1.792 0 0.16-0.032 0.352-0.064 0.416 0 0.064-0.064 0.256-0.064 0.384-0.032 0.16-0.096 0.416-0.096 0.544-0.224 1.216-0.224 1.76 0 2.24 0.128 0.224 0.288 0.352 0.576 0.512 0.384 0.192 0.512 0.192 1.216 0.192 0.608 0 0.896-0.032 1.28-0.192 0.608-0.224 0.672-0.352 0.544-0.928-0.096-0.512-0.032-1.408 0.192-2.464 0.032-0.224 0.096-0.576 0.128-0.736 0.032-0.192 0.096-0.608 0.16-0.928 0.064-0.288 0.096-0.576 0.096-0.608s0-0.064 0.032-0.096c0.032-0.096 0.064-0.288 0.096-0.672 0.032-0.224 0.096-0.448 0.096-0.512 0.032-0.064 0.064-0.256 0.096-0.416 0-0.16 0.064-0.384 0.064-0.448 0.032-0.128 0.064-0.32 0.096-0.48s0.064-0.352 0.064-0.448c0.224-1.088 0.32-2.272 0.192-2.848-0.096-0.512-0.128-0.576-0.256-0.832-0.416-0.8-1.12-1.184-2.432-1.248-0.608-0.032-2.464 0.448-2.464 0.64 0 0.064 0 0.064-0.032 0.032s-0.384 0.128-0.736 0.32l-0.704 0.352-0.16-0.224c-0.224-0.416-0.608-0.736-1.088-0.896-0.48-0.192-1.504-0.288-1.952-0.16zM21.536 6.048c0 0.032-0.224 0.064-0.48 0.064-0.544 0.064-1.184 0.224-1.184 0.352 0 0.032-0.032 0.032-0.064 0.032-0.032-0.032-0.128 0-0.224 0.096-0.128 0.16-0.128 0.192 0.032 0.832 0.064 0.224 0.032 0.864-0.064 1.376-0.064 0.288-0.128 0.608-0.128 0.768 0 0.128-0.064 0.416-0.128 0.64-0.032 0.224-0.096 0.544-0.128 0.704-0.064 0.544-0.096 0.704-0.16 0.864 0 0.064-0.064 0.32-0.064 0.544-0.032 0.224-0.064 0.416-0.096 0.448 0 0.032-0.064 0.224-0.096 0.48-0.032 0.224-0.064 0.48-0.064 0.544-0.032 0.064-0.064 0.256-0.096 0.416-0.096 0.544-0.128 0.8-0.16 1.024-0.16 0.896-0.096 2.208 0.096 2.624 0.064 0.096 0.128 0.256 0.192 0.384 0.16 0.352 0.704 0.896 1.056 1.024 0.928 0.384 1.664 0.416 2.784 0.128 0.224-0.064 0.416-0.128 0.448-0.128 0.064 0 0.16-0.064 0.256-0.096 0.704-0.288 1.472-0.544 1.504-0.512 0 0 0.064 0.128 0.128 0.256 0.288 0.608 0.896 0.864 1.888 0.864 0.64-0.032 1.536-0.256 1.632-0.416 0.032-0.032 0.096-0.064 0.128-0.096 0.032 0 0.064-0.16 0.064-0.384-0.096-1.248-0.096-1.472-0.032-1.76 0.032-0.16 0.096-0.416 0.128-0.576 0.064-0.576 0.128-0.96 0.16-1.12 0.032-0.096 0.064-0.288 0.096-0.448s0.064-0.384 0.096-0.48c0-0.096 0.032-0.288 0.064-0.448s0.096-0.576 0.16-0.896c0.064-0.288 0.128-0.576 0.096-0.608s0-0.096 0.032-0.16c0.032-0.096 0.096-0.32 0.128-0.512 0.032-0.224 0.064-0.48 0.096-0.608 0.032-0.192 0.32-1.792 0.416-2.272 0-0.16 0.064-0.352 0.064-0.48 0.128-0.448 0.064-1.312-0.096-1.632-0.128-0.288-0.736-0.768-0.832-0.672-0.032 0.032-0.096 0-0.16-0.032-0.096-0.096-1.088-0.128-1.44-0.032-0.448 0.096-1.056 0.32-1.184 0.416-0.096 0.096-0.096 0.192-0.032 0.544 0.096 0.448 0.096 1.312 0 1.824-0.032 0.16-0.128 0.576-0.192 0.928-0.064 0.32-0.096 0.64-0.096 0.64 0 0.032 0 0.096 0 0.128-0.032 0.064-0.096 0.352-0.128 0.576-0.032 0.192-0.128 0.704-0.192 1.024-0.032 0.096-0.064 0.32-0.064 0.48-0.032 0.16-0.064 0.32-0.064 0.384-0.032 0.032-0.064 0.256-0.096 0.48-0.064 0.224-0.096 0.448-0.096 0.48 0 0-0.064 0.32-0.128 0.704-0.096 0.576-0.128 0.64-0.352 0.736-0.128 0.064-0.224 0.128-0.192 0.128 0.032 0.032-0.032 0.064-0.096 0.064-0.096 0-0.32 0.064-0.512 0.16-0.864 0.32-1.856 0.064-1.92-0.512 0-0.096-0.032-0.224-0.032-0.288 0-0.16 0.16-1.472 0.192-1.472 0 0 0.032-0.064 0.032-0.16s0.032-0.288 0.064-0.416c0.032-0.128 0.096-0.384 0.096-0.512 0.128-0.704 0.192-1.152 0.256-1.44 0.032-0.128 0.064-0.384 0.096-0.544 0.032-0.192 0.128-0.8 0.256-1.344 0.288-1.632 0.16-2.432-0.416-2.784-0.16-0.064-0.288-0.16-0.352-0.16-0.512-0.096-0.864-0.16-0.896-0.16z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Save</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="/cdn-cgi/l/email-protection#0d327e786f67686e79305d627f66283f3d5f646f7e283f3d7a647965283f3d4f616c6e66283f3d4f686c63283f3d5e6c786e682b6c607d366f626974306579797d7e283e4c283f4b283f4b7965687a62667e626b61646b68236e6260283f4b7d627f66207f646f7e206f616c6e66206f686c63207e6c786e68283f4b" class="dpsp-network-btn dpsp-email dpsp-no-label dpsp-last" target="_blank" title="Send over email"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="32" viewBox="0 0 28 32"><path d="M18.56 17.408l8.256 8.544h-25.248l8.288-8.448 4.32 4.064zM2.016 6.048h24.32l-12.16 11.584zM20.128 15.936l8.224-7.744v16.256zM0 24.448v-16.256l8.288 7.776z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="32" viewBox="0 0 28 32"><path d="M18.56 17.408l8.256 8.544h-25.248l8.288-8.448 4.32 4.064zM2.016 6.048h24.32l-12.16 11.584zM20.128 15.936l8.224-7.744v16.256zM0 24.448v-16.256l8.288 7.776z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label"></span></span></a></li></ul></div><span id="dpsp-post-content-markup" data-image-pin-it="false"></span><p><span style="font-weight: 400;">I don’t make pork ribs with black bean sauce very often, but when I do, I always wonder why I’m not making it all the time. </span></p><p><span style="font-weight: 400;">This saucy pork rib dish over rice is total comfort food and a perfect one-plate meal. Ribs with black bean sauce takes a little bit of time to get tender, succulent, fall-off-the-bone meat, but it’s very easy to make, and the first step can be done ahead of time! Please note that this ribs with black bean sauce dish is cooked and stir fried in the wok and NOT steamed. We have a separate recipe for <a href="https://thewoksoflife.com/dim-sum-spare-ribs-w-black-beans/" target="_blank" rel="noopener noreferrer">steamed pork ribs with fermented black beans</a> &#8211; the kind you find at Chinese dim sum restaurants.</span></p><h2>What Are Chinese Fermented Black Beans?<b> </b></h2><p><span style="font-weight: 400;">The black beans in “black bean sauce” aren’t the black beans you’d find in a can from the supermarket. They are Chinese </span><a href="https://thewoksoflife.com/fermented-black-beans/" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">fermented black beans</span></a><span style="font-weight: 400;">, made from black soybeans. </span></p><p><img class="aligncenter size-full wp-image-39597" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20470'%3E%3C/svg%3E" alt="Pork Ribs in Black Bean Sauce Ingredients, thewoksoflife.com" width="650" height="470" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-2.jpg" /><noscript><img class="aligncenter size-full wp-image-39597" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-2.jpg" alt="Pork Ribs in Black Bean Sauce Ingredients, thewoksoflife.com" width="650" height="470" /></noscript></p><p><span style="font-weight: 400;">They have a salty bite and strong umami flavor. You can find them in <a href="https://thewoksoflife.com/navigating-a-chinese-grocery-store/" target="_blank" rel="noopener noreferrer">Chinese grocery stores</a>, and the good news is, they are very inexpensive! A one pound bag of them costs around $2! We like to say that they’re the biggest flavor bang for your buck at the Chinese market. </span></p><p><span style="font-weight: 400;">I remember one of my teachers in high school telling me how she loved fermented black beans. She described it as looking and smelling strange, but fell in love with them after the first taste! Ribs with black bean sauce was one of the dishes I recommended to her.</span></p><h2>Chopping Ribs Into Smaller Pieces</h2><p>You can use any pork ribs for this dish––boneless country ribs, baby back ribs, or St. Louis-style ribs. If using bone-in ribs, you&#8217;ll have to use a cleaver to cut through the bone and make them into smaller pieces. You can also ask your butcher to do this for you.</p><p>Here&#8217;s a quick video demonstrating how to chop the ribs. <strong>Don&#8217;t try this with a regular chef&#8217;s knife.</strong> They weren&#8217;t meant to chop through bone, and you will probably chip your knife.</p><p>Instead, use a heavy Chinese cleaver. As you can see, the one I&#8217;m using is very heavy and thick. It was designed for chopping through bones like this.</p><p>Position a damp dish towel underneath the cutting board to create an anti-slip surface. It also serves as padding for your countertop, to help absorb the shock of the knife&#8217;s motion.</p><p><iframe title="Cutting Pork Ribs with a Chinese Cleaver" width="500" height="281" src="https://www.youtube.com/embed/ttSOZevZKu0?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><h2>How We Used to Make This in Restaurants!<b> </b></h2><p><span style="font-weight: 400;">Pork Ribs in Black Bean Sauce was on the menu at the first Chinese American restaurant I ever worked at in upstate New York. I can’t say that it was a super-popular dish, because back in the 70s, fermented black bean sauce wasn’t as popular as it is today.</span></p><p><span style="font-weight: 400;">After my father tutored me on my <a href="https://thewoksoflife.com/how-to/chinese-cooking-tools/#cleaver" target="_blank" rel="noopener noreferrer">cleaver</a> skills, I was tasked with chopping the pork ribs in bite-sized pieces. We used to make 10 orders of these ribs at a time. I would pre-cook the pork ribs for 30 to 40 minutes until tender, let them cool off, and wrap each order in plastic––ready to go when a customer ordered the dish. </span></p><p><span style="font-weight: 400;">Which brings me to the next question you’re probably wondering about&#8230;.</span></p><h2>How Can I Make This Dish In Advance?</h2><p><span style="font-weight: 400;">Excluding the initial effort of pre-cooking the pork ribs, I consider this a quick and easy dish.</span></p><p><span style="font-weight: 400;">You can use the same method we used at the restaurant to prep orders. Simply freeze individual or family-sized portions of pre-cooked ribs. That way, you can make pork ribs and black bean sauce quickly any time of the week.</span></p><p><span style="font-weight: 400;">All you have to do is the first step of the recipe (boiling lightly salted water and simmering the ribs for 40 minutes until tender). Then drain, allow them to cool, and freeze portions of the ribs along with the pork stock freezer bags and/or storage containers. </span></p><p><span style="font-weight: 400;">Then simply take them out of the freezer the night before, or a few hours before you’re ready to cook. The final stir-frying of the pork ribs and the sauce is very quick.</span></p><p><img class="aligncenter size-full wp-image-39614" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20978'%3E%3C/svg%3E" alt="Pork Ribs in Black Bean Sauce, thewoksoflife.com" width="650" height="978" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-19.jpg" /><noscript><img class="aligncenter size-full wp-image-39614" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-19.jpg" alt="Pork Ribs in Black Bean Sauce, thewoksoflife.com" width="650" height="978" /></noscript></p><p><span style="font-weight: 400;">On to the recipe!</span></p><h2>Pork Ribs with Black Bean Sauce: Recipe Instructions</h2><p><span style="font-weight: 400;">Bring 5 cups of water to a boil and add ¼ teaspoon salt. Add the ribs and simmer for 40 minutes, turning the ribs occasionally until they are tender.</span></p><p><span style="font-weight: 400;"> <img class="aligncenter size-full wp-image-39598" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Boiling pork ribs, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-3.jpg" /><noscript><img class="aligncenter size-full wp-image-39598" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-3.jpg" alt="Boiling pork ribs, thewoksoflife.com" width="650" height="432" /></noscript></span></p><p>By the end of the 40 minutes, the liquid will have reduced quite a bit.</p><p><img class="aligncenter size-full wp-image-39599" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Simmering Pork Ribs, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-4.jpg" /><noscript><img class="aligncenter size-full wp-image-39599" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-4.jpg" alt="Simmering Pork Ribs, thewoksoflife.com" width="650" height="432" /></noscript></p><p><span style="font-weight: 400;">Remove the ribs to a plate&#8230;</span></p><p><img class="aligncenter size-full wp-image-39600" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20642'%3E%3C/svg%3E" alt="Removing boiled pork ribs to plate, thewoksoflife.com" width="650" height="642" data-lazy-srcset="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-5.jpg 650w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-5-100x100.jpg 100w" data-lazy-sizes="(max-width: 650px) 100vw, 650px" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-5.jpg" /><noscript><img class="aligncenter size-full wp-image-39600" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-5.jpg" alt="Removing boiled pork ribs to plate, thewoksoflife.com" width="650" height="642" srcset="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-5.jpg 650w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-5-100x100.jpg 100w" sizes="(max-width: 650px) 100vw, 650px" /></noscript></p><p><span style="font-weight: 400;">And pour the pork stock (the liquid you boiled the ribs in) through a <a href="https://thewoksoflife.com/how-to/chinese-cooking-tools/#fine-mesh-strainer" target="_blank" rel="noopener noreferrer">fine mesh strainer</a>. You should have 1 to 1 ½ cups of liquid. </span></p><p><span style="font-weight: 400;"><img class="aligncenter size-full wp-image-39601" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20419'%3E%3C/svg%3E" alt="Straining pork stock, thewoksoflife.com" width="650" height="419" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-6.jpg" /><noscript><img class="aligncenter size-full wp-image-39601" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-6.jpg" alt="Straining pork stock, thewoksoflife.com" width="650" height="419" /></noscript></span></p><p><span style="font-weight: 400;">Heat the oil in a wok over medium heat. Add the smashed ginger, and fry until caramelized (15-30 seconds). </span></p><p><img class="aligncenter size-full wp-image-39602" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20434'%3E%3C/svg%3E" alt="Smashed ginger in wok, thewoksoflife.com" width="650" height="434" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-7.jpg" /><noscript><img class="aligncenter size-full wp-image-39602" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-7.jpg" alt="Smashed ginger in wok, thewoksoflife.com" width="650" height="434" /></noscript></p><p><span style="font-weight: 400;">Add the garlic, <a href="https://thewoksoflife.com/chinese-sauces-vinegars-oils/#fermented-black-bean" target="_blank" rel="noopener noreferrer">fermented black beans</a>, onions, and peppers. </span></p><p><img class="aligncenter size-full wp-image-39605" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Onions, peppers, black beans in wok, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-10.jpg" /><noscript><img class="aligncenter size-full wp-image-39605" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-10.jpg" alt="Onions, peppers, black beans in wok, thewoksoflife.com" width="650" height="432" /></noscript></p><p><span style="font-weight: 400;">Stir-fry for 1 minute, and add the pork ribs. </span></p><p><img class="aligncenter size-full wp-image-39606" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Adding pork ribs to wok, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-11.jpg" /><noscript><img class="aligncenter size-full wp-image-39606" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-11.jpg" alt="Adding pork ribs to wok, thewoksoflife.com" width="650" height="432" /></noscript></p><p><span style="font-weight: 400;">Then add the <a href="https://thewoksoflife.com/shaoxing-wine-the-key-to-authentic-chinese-cooking/" target="_blank" rel="noopener noreferrer">Shaoxing wine</a>. </span></p><p><img class="aligncenter size-full wp-image-39607" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Shaoxing wine, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-12.jpg" /><noscript><img class="aligncenter size-full wp-image-39607" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-12.jpg" alt="Shaoxing wine, thewoksoflife.com" width="650" height="432" /></noscript></p><p><span style="font-weight: 400;">Next, add the pork stock (1 to 1 1/2 cups), and bring to a simmer. You can add more stock or water if you like your ribs saucy.</span></p><p><span style="font-weight: 400;"> <img class="aligncenter size-full wp-image-39608" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Adding pork stock, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-13.jpg" /><noscript><img class="aligncenter size-full wp-image-39608" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-13.jpg" alt="Adding pork stock, thewoksoflife.com" width="650" height="432" /></noscript></span></p><p><span style="font-weight: 400;">Add the sugar, <a href="https://thewoksoflife.com/chinese-spices-condiments/#white-pepper">white pepper</a>, <a href="https://thewoksoflife.com/chinese-sauces-vinegars-oils/#sesame-oil">sesame oil</a>, <a href="https://thewoksoflife.com/soy-sauce/" target="_blank" rel="noopener noreferrer">soy sauce</a>, and <a href="https://thewoksoflife.com/chinese-sauces-vinegars-oils/#dark-soy-sauce" target="_blank" rel="noopener noreferrer">dark soy sauce</a>. Stir and simmer for 2 minutes. Give the sauce a taste, and re-season if necessary. </span></p><p><img class="aligncenter size-full wp-image-39609" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Simmering pork ribs in black bean sauce, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-14.jpg" /><noscript><img class="aligncenter size-full wp-image-39609" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-14.jpg" alt="Simmering pork ribs in black bean sauce, thewoksoflife.com" width="650" height="432" /></noscript></p><p><span style="font-weight: 400;">Make sure the cornstarch is evenly mixed with the water, and pour in the slurry. For more details on using cornstarch slurry, see our complete article on <a href="https://thewoksoflife.com/how-to-use-cornstarch-chinese-cooking/" target="_blank" rel="noopener noreferrer">how to use cornstarch in Chinese cooking</a>.</span></p><p><img class="aligncenter size-full wp-image-39610" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Adding cornstarch slurry to thicken sauce, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-15.jpg" /><noscript><img class="aligncenter size-full wp-image-39610" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-15.jpg" alt="Adding cornstarch slurry to thicken sauce, thewoksoflife.com" width="650" height="432" /></noscript></p><p><span style="font-weight: 400;">Stir to allow the sauce to thicken. If it’s too thick, add a little splash of water. If it’s too thin, add more cornstarch slurry. </span><span style="font-weight: 400;">Toss in the chopped scallions.</span></p><p><img class="aligncenter size-full wp-image-39611" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20432'%3E%3C/svg%3E" alt="Adding chopped scallions, thewoksoflife.com" width="650" height="432" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-16.jpg" /><noscript><img class="aligncenter size-full wp-image-39611" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-16.jpg" alt="Adding chopped scallions, thewoksoflife.com" width="650" height="432" /></noscript></p><p><span style="font-weight: 400;">Serve with rice.</span></p><p><img class="aligncenter size-full wp-image-39613" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20650%20923'%3E%3C/svg%3E" alt="Chinese Pork Ribs with Black Bean Sauce, thewoksoflife.com" width="650" height="923" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-18.jpg" /><noscript><img class="aligncenter size-full wp-image-39613" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-18.jpg" alt="Chinese Pork Ribs with Black Bean Sauce, thewoksoflife.com" width="650" height="923" /></noscript></p><div id="wprm-recipe-container-39999" class="wprm-recipe-container" data-recipe-id="39999"><div class="wprm-recipe wprm-recipe-template-woks-of-life-compact"><div class="wprm-container-float-right"><div class="wprm-recipe-image wprm-block-image-normal"><img style="border-width: 0px;border-style: solid;border-color: #666666;" width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-150x150 size-150x150" alt="Chinese Ribs with Black Bean Sauce, thewoksoflife.com" data-lazy-srcset="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-150x150.jpg 150w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-200x200.jpg 200w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-100x100.jpg 100w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-500x500.jpg 500w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-266x266.jpg 266w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-150x150.jpg" /><noscript><img style="border-width: 0px;border-style: solid;border-color: #666666;" width="150" height="150" src="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-150x150.jpg" class="attachment-150x150 size-150x150" alt="Chinese Ribs with Black Bean Sauce, thewoksoflife.com" srcset="https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-150x150.jpg 150w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-200x200.jpg 200w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-100x100.jpg 100w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-500x500.jpg 500w, https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17-266x266.jpg 266w" sizes="(max-width: 150px) 100vw, 150px" /></noscript></div><div class="wprm-spacer" style="height: 5px"></div> <a href="https://thewoksoflife.com/wprm_print/39999" style="color: #ffffff;background-color: #666666;border-color: #666666;border-radius: 8px;padding: 5px 5px;" class="wprm-recipe-print wprm-recipe-link wprm-print-recipe-shortcode wprm-block-text-normal wprm-recipe-print-wide-button wprm-recipe-link-wide-button wprm-color-accent" data-recipe-id="39999" target="_blank" rel="nofollow"><span class="wprm-recipe-icon wprm-recipe-print-icon"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g><path fill="#ffffff" d="M19,5.09V1c0-0.552-0.448-1-1-1H6C5.448,0,5,0.448,5,1v4.09C2.167,5.569,0,8.033,0,11v7c0,0.552,0.448,1,1,1h4v4c0,0.552,0.448,1,1,1h12c0.552,0,1-0.448,1-1v-4h4c0.552,0,1-0.448,1-1v-7C24,8.033,21.833,5.569,19,5.09z M7,2h10v3H7V2z M17,22H7v-9h10V22z M18,10c-0.552,0-1-0.448-1-1c0-0.552,0.448-1,1-1s1,0.448,1,1C19,9.552,18.552,10,18,10z" /></g></svg></span> Print Recipe</a><style>.wprm-recipe-rating .wprm-rating-star.wprm-rating-star-full svg * { fill: #fecd00; }</style><div class="wprm-recipe-rating wprm-recipe-rating-separate"><span class="wprm-rating-star wprm-rating-star-1 wprm-rating-star-full" data-rating="1" data-color="#fecd00"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#fecd00" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><span class="wprm-rating-star wprm-rating-star-2 wprm-rating-star-full" data-rating="2" data-color="#fecd00"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#fecd00" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><span class="wprm-rating-star wprm-rating-star-3 wprm-rating-star-full" data-rating="3" data-color="#fecd00"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#fecd00" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><span class="wprm-rating-star wprm-rating-star-4 wprm-rating-star-full" data-rating="4" data-color="#fecd00"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#fecd00" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><span class="wprm-rating-star wprm-rating-star-5 wprm-rating-star-full" data-rating="5" data-color="#fecd00"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#fecd00" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><div class="wprm-recipe-rating-details wprm-block-text-normal"><span class="wprm-recipe-rating-average">5</span> from <span class="wprm-recipe-rating-count">1</span> vote</div></div></div><h2 class="wprm-recipe-name wprm-block-text-bold">Pork Ribs with Black Bean Sauce</h2><div class="wprm-spacer" style="height: 5px"></div><div class="wprm-recipe-summary wprm-block-text-normal"><span style="display: block;">Pork ribs with black bean sauce is a tasty, savory Chinese comfort food  recipe, perfect as a one-plate meal with rice. </span></div><div class="wprm-spacer"></div><div class="wprm-recipe-meta-container wprm-recipe-times-container wprm-recipe-details-container wprm-recipe-details-container-table wprm-block-text-normal wprm-recipe-table-borders-top-bottom wprm-recipe-table-borders-inside" style="border-width: 1px;border-style: solid;border-color: #777777;"><div class="wprm-recipe-block-container wprm-recipe-block-container-table wprm-block-text-normal wprm-recipe-time-container wprm-recipe-prep-time-container" style="border-width: 1px;border-style: solid;border-color: #777777;"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-time-label wprm-recipe-prep-time-label">Prep Time</span><span class="wprm-recipe-time wprm-block-text-normal"><span class="wprm-recipe-details wprm-recipe-details-minutes wprm-recipe-prep_time wprm-recipe-prep_time-minutes">15</span> <span class="wprm-recipe-details-unit wprm-recipe-details-minutes wprm-recipe-prep_time-unit wprm-recipe-prep_timeunit-minutes">mins</span></span></div><div class="wprm-recipe-block-container wprm-recipe-block-container-table wprm-block-text-normal wprm-recipe-time-container wprm-recipe-cook-time-container" style="border-width: 1px;border-style: solid;border-color: #777777;"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-time-label wprm-recipe-cook-time-label">Cook Time</span><span class="wprm-recipe-time wprm-block-text-normal"><span class="wprm-recipe-details wprm-recipe-details-minutes wprm-recipe-cook_time wprm-recipe-cook_time-minutes">45</span> <span class="wprm-recipe-details-unit wprm-recipe-details-minutes wprm-recipe-cook_time-unit wprm-recipe-cook_timeunit-minutes">mins</span></span></div><div class="wprm-recipe-block-container wprm-recipe-block-container-table wprm-block-text-normal wprm-recipe-time-container wprm-recipe-total-time-container" style="border-width: 1px;border-style: solid;border-color: #777777;"><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-time-label wprm-recipe-total-time-label">Total Time</span><span class="wprm-recipe-time wprm-block-text-normal"><span class="wprm-recipe-details wprm-recipe-details-hours wprm-recipe-total_time wprm-recipe-total_time-hours">1</span> <span class="wprm-recipe-details-unit wprm-recipe-details-unit-hours wprm-recipe-total_time-unit wprm-recipe-total_timeunit-hours">hr</span></span></div></div><div class="wprm-spacer" style="height: 5px"></div><div class="wprm-recipe-meta-container wprm-recipe-tags-container wprm-recipe-details-container wprm-recipe-details-container-inline wprm-block-text-normal" style=""><div class="wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal wprm-recipe-tag-container wprm-recipe-course-container" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-tag-label wprm-recipe-course-label">Course: </span><span class="wprm-recipe-course wprm-block-text-normal">Pork</span></div><div class="wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal wprm-recipe-tag-container wprm-recipe-cuisine-container" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-tag-label wprm-recipe-cuisine-label">Cuisine: </span><span class="wprm-recipe-cuisine wprm-block-text-normal">Chinese</span></div><div class="wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal wprm-recipe-tag-container wprm-recipe-keyword-container" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-tag-label wprm-recipe-keyword-label">Keyword: </span><span class="wprm-recipe-keyword wprm-block-text-normal">pork ribs with black bean sauce</span></div></div><div class="wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal wprm-recipe-servings-container" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-servings-label">Servings: </span><span class="wprm-recipe-servings wprm-recipe-details wprm-recipe-servings-39999 wprm-recipe-servings-adjustable-tooltip wprm-block-text-normal" data-recipe="39999" aria-label="Adjust recipe servings">6</span></div><div class="wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal wprm-recipe-nutrition-container wprm-recipe-calories-container" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-nutrition-label wprm-recipe-calories-label">Calories: </span><span class="wprm-recipe-nutrition-with-unit"><span class="wprm-recipe-details wprm-recipe-nutrition wprm-recipe-calories wprm-block-text-normal">321</span><span class="wprm-recipe-details-unit wprm-recipe-nutrition-unit wprm-recipe-calories-unit wprm-block-text-normal">kcal</span></span></div><div class="wprm-recipe-block-container wprm-recipe-block-container-inline wprm-block-text-normal wprm-recipe-author-container" style=""><span class="wprm-recipe-details-label wprm-block-text-faded wprm-recipe-author-label">Author: </span><span class="wprm-recipe-details wprm-recipe-author wprm-block-text-normal">Bill</span></div><div class="wprm-recipe-ingredients-container wprm-block-text-normal"><h3 class="wprm-recipe-header wprm-recipe-ingredients-header wprm-block-text-bold wprm-align-left wprm-header-decoration-none" style="">Ingredients</h3><div class="wprm-recipe-ingredient-group"><ul class="wprm-recipe-ingredients"><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">5</span> <span class="wprm-recipe-ingredient-unit">cups</span> <span class="wprm-recipe-ingredient-name">water</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1/4</span> <span class="wprm-recipe-ingredient-unit">teaspoon</span> <span class="wprm-recipe-ingredient-name">salt</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1 3/4</span> <span class="wprm-recipe-ingredient-unit">pounds</span> <span class="wprm-recipe-ingredient-name">pork ribs</span> <span class="wprm-recipe-ingredient-notes wprm-recipe-ingredient-notes-faded">(800g, cut into 1 1/2 inch chunks)</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">tablespoon</span> <span class="wprm-recipe-ingredient-name">vegetable oil</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">slice</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/chinese-chives-scallions-aromatics-peppers/#ginger" target="_blank">ginger</a></span> <span class="wprm-recipe-ingredient-notes wprm-recipe-ingredient-notes-faded">(smashed)</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">2</span> <span class="wprm-recipe-ingredient-unit">cloves</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/chinese-chives-scallions-aromatics-peppers/#garlic" target="_blank">garlic</a></span> <span class="wprm-recipe-ingredient-notes wprm-recipe-ingredient-notes-faded">(chopped)</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">3</span> <span class="wprm-recipe-ingredient-unit">tablespoons</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/fermented-black-beans/" target="_blank">fermented black beans</a></span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1/2</span> <span class="wprm-recipe-ingredient-name">green bell pepper</span> <span class="wprm-recipe-ingredient-notes wprm-recipe-ingredient-notes-faded">(or 1 large long hot green pepper or poblano pepper)</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-name">medium onion</span> <span class="wprm-recipe-ingredient-notes wprm-recipe-ingredient-notes-faded">(cut into 1 inch chunks)</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">tablespoon</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/shaoxing-wine-the-key-to-authentic-chinese-cooking/" target="_blank">Shaoxing wine</a></span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1/2</span> <span class="wprm-recipe-ingredient-unit">teaspoon</span> <span class="wprm-recipe-ingredient-name">sugar</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1/8</span> <span class="wprm-recipe-ingredient-unit">teaspoon</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/chinese-spices-condiments/#white-pepper" target="_blank">white pepper</a></span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1/2</span> <span class="wprm-recipe-ingredient-unit">teaspoon</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/sesame-oil/" target="_blank">sesame oil</a></span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">2 1/2</span> <span class="wprm-recipe-ingredient-unit">teaspoons</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/soy-sauce/" target="_blank">light soy sauce</a></span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1/2</span> <span class="wprm-recipe-ingredient-unit">teaspoon</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/dark-soy-sauce/" target="_blank">dark soy sauce</a></span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">1</span> <span class="wprm-recipe-ingredient-unit">tablespoon</span> <span class="wprm-recipe-ingredient-name"><a href="https://thewoksoflife.com/rice-grains-and-flours/#cornstarch" target="_blank">cornstarch</a></span> <span class="wprm-recipe-ingredient-notes wprm-recipe-ingredient-notes-faded">(mixed with 2 tablespoons water)</span></li><li class="wprm-recipe-ingredient" style="list-style-type: disc;"><span class="wprm-recipe-ingredient-amount">2</span> <span class="wprm-recipe-ingredient-name"><a href="https:/thewoksoflife.com/chinese-chives-scallions-aromatics-peppers/#scallions" target="_blank">scallions</a></span> <span class="wprm-recipe-ingredient-notes wprm-recipe-ingredient-notes-faded">(chopped)</span></li></ul></div></div><div class="wprm-recipe-instructions-container wprm-block-text-normal"><h3 class="wprm-recipe-header wprm-recipe-instructions-header wprm-block-text-bold wprm-align-left wprm-header-decoration-none" style="">Instructions</h3><div class="wprm-recipe-instruction-group"><ul class="wprm-recipe-instructions"><li id="wprm-recipe-39999-step-0-0" class="wprm-recipe-instruction" style="list-style-type: decimal;"><div class="wprm-recipe-instruction-text" style="margin-bottom: 5px"><span style="display: block;">Bring the water to a boil and add ¼ teaspoon salt. Add the ribs and simmer for 40 minutes, turning the ribs occasionally until they are tender. Remove the ribs to a plate and pour the pork stock (the liquid you boiled the ribs in) through a fine mesh strainer. You should have 1 to 1 ½ cups of liquid. </span></div></li><li id="wprm-recipe-39999-step-0-1" class="wprm-recipe-instruction" style="list-style-type: decimal;"><div class="wprm-recipe-instruction-text" style="margin-bottom: 5px"><span style="display: block;">Heat the oil in a wok over medium heat. Add the smashed ginger, and fry until caramelized (15-30 seconds). Add the garlic, black beans, onions, and peppers. Stir-fry for 1 minute, and add the pork ribs. Then add the Shaoxing wine. </span></div></li><li id="wprm-recipe-39999-step-0-2" class="wprm-recipe-instruction" style="list-style-type: decimal;"><div class="wprm-recipe-instruction-text" style="margin-bottom: 5px"><span style="display: block;">Next, add the pork stock (1 to 1 1/2 cups), and bring to a simmer. You can add more stock or water if you like your ribs saucy.</span></div></li><li id="wprm-recipe-39999-step-0-3" class="wprm-recipe-instruction" style="list-style-type: decimal;"><div class="wprm-recipe-instruction-text" style="margin-bottom: 5px"><span style="display: block;">Add the sugar, white pepper, sesame oil, soy sauce, and dark soy sauce. Stir and simmer for 2 minutes. Give the sauce a taste, and re-season if necessary. </span></div></li><li id="wprm-recipe-39999-step-0-4" class="wprm-recipe-instruction" style="list-style-type: decimal;"><div class="wprm-recipe-instruction-text" style="margin-bottom: 5px"><span style="display: block;">Make sure the cornstarch is evenly mixed with the water, and pour in the slurry. Stir to allow the sauce to thicken. If it’s too thick, add a little splash of water. If it’s too thin, add more cornstarch slurry. Toss in the chopped scallions, and serve with rice. </span></div></li></ul></div></div><div class="wprm-recipe-notes-container wprm-block-text-normal"><h3 class="wprm-recipe-header wprm-recipe-notes-header wprm-block-text-bold wprm-align-left wprm-header-decoration-none" style="">Notes</h3><div class="wprm-recipe-notes"><span style="display: block;"><span style="font-weight: 400">For make-ahead meal prep, you can complete the first step of the recipe in advance and freeze portions of the cooked ribs along with the pork stock. Remove from the freezer the night before you want to make the dish. </span></span></div></div><h3 class="wprm-recipe-header wprm-recipe-nutrition-header wprm-block-text-bold wprm-align-left wprm-header-decoration-none" style="">Nutrition</h3><div class="wprm-nutrition-label-container wprm-nutrition-label-container-simple wprm-block-text-normal" style="text-align: left;"><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Calories: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">321</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">kcal</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Carbohydrates: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">6</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Protein: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">17</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Fat: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">25</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Saturated Fat: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">9</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Cholesterol: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">74</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Sodium: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">652</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Potassium: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">279</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Fiber: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">1</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Sugar: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">2</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">g</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Vitamin A: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">77</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">IU</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Vitamin C: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">10</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Calcium: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">29</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span><span style="color: #777777"> | </span><span class="wprm-nutrition-label-text-nutrition-container"><span class="wprm-nutrition-label-text-nutrition-label  wprm-block-text-normal" style="color: #777777">Iron: </span><span class="wprm-nutrition-label-text-nutrition-value" style="color: #333333">1</span><span class="wprm-nutrition-label-text-nutrition-unit" style="color: #333333">mg</span></span></div></div></div><div class="relpost-thumb-wrapper"><div class="relpost-thumb-container"><h3>YOU MIGHT ALSO LIKE:</h3><div style="clear: both"></div><div style="clear: both"></div><div class="relpost-block-container"><a class="relpost-block-single" href="https://thewoksoflife.com/five-spice-fried-chicken-drumsticks/"><div style="width: 200px; height: 275px;"><div class="relpost-block-single-image" alt="Five Spice Fried Chicken, by thewoksoflife.com" style="background: transparent url(https://thewoksoflife.com/wp-content/uploads/2014/11/five-spice-fried-chicken-7-200x200.jpg) no-repeat scroll 0% 0%; width: 200px; height: 200px;"></div><div class="relpost-block-single-text" style="font-family: Arial;  font-size: 12px;  color: #333333;">Five Spice Fried Chicken Drumsticks</div></div></a><a class="relpost-block-single" href="https://thewoksoflife.com/soy-sauce-mushroom-noodles/"><div style="width: 200px; height: 275px;"><div class="relpost-block-single-image" alt="Soy Sauce Braised Wild Mushroom Noodles, by thewoksoflife.com" style="background: transparent url(https://thewoksoflife.com/wp-content/uploads/2017/04/mushroom-noodles-6-200x200.jpg) no-repeat scroll 0% 0%; width: 200px; height: 200px;"></div><div class="relpost-block-single-text" style="font-family: Arial;  font-size: 12px;  color: #333333;">Soy Sauce Braised Wild Mushroom Noodles</div></div></a><a class="relpost-block-single" href="https://thewoksoflife.com/chinese-braised-duck-legs/"><div style="width: 200px; height: 275px;"><div class="relpost-block-single-image" alt="Chinese Braised Duck Legs, thewoksoflife.com" style="background: transparent url(https://thewoksoflife.com/wp-content/uploads/2020/04/chinese-braised-duck-6-200x200.jpg) no-repeat scroll 0% 0%; width: 200px; height: 200px;"></div><div class="relpost-block-single-text" style="font-family: Arial;  font-size: 12px;  color: #333333;">Chinese Braised Duck Legs</div></div></a></div><div style="clear: both"></div></div></div><div id="dpsp-content-bottom" class="dpsp-content-wrapper dpsp-shape-circle dpsp-size-small dpsp-has-spacing dpsp-show-on-mobile dpsp-button-style-6"><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content dpsp-networks-btns-share dpsp-column-auto "><li><a rel="nofollow noopener noreferrer" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthewoksoflife.com%2Fpork-ribs-black-bean-sauce%2F&t=Pork%20Ribs%20with%20Black%20Bean%20Sauce" class="dpsp-network-btn dpsp-facebook dpsp-first" target="_blank" title="Share on Facebook"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="18" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="18" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Share</span></span></a></li><li><a rel="nofollow noopener noreferrer" data-href="#" class="dpsp-network-btn dpsp-pinterest" target="_blank" title="Save to Pinterest"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="23" height="32" viewBox="0 0 23 32"><path d="M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="23" height="32" viewBox="0 0 23 32"><path d="M0 10.656q0-1.92 0.672-3.616t1.856-2.976 2.72-2.208 3.296-1.408 3.616-0.448q2.816 0 5.248 1.184t3.936 3.456 1.504 5.12q0 1.728-0.32 3.36t-1.088 3.168-1.792 2.656-2.56 1.856-3.392 0.672q-1.216 0-2.4-0.576t-1.728-1.568q-0.16 0.704-0.48 2.016t-0.448 1.696-0.352 1.28-0.48 1.248-0.544 1.12-0.832 1.408-1.12 1.536l-0.224 0.096-0.16-0.192q-0.288-2.816-0.288-3.36 0-1.632 0.384-3.68t1.184-5.152 0.928-3.616q-0.576-1.152-0.576-3.008 0-1.504 0.928-2.784t2.368-1.312q1.088 0 1.696 0.736t0.608 1.824q0 1.184-0.768 3.392t-0.8 3.36q0 1.12 0.8 1.856t1.952 0.736q0.992 0 1.824-0.448t1.408-1.216 0.992-1.696 0.672-1.952 0.352-1.984 0.128-1.792q0-3.072-1.952-4.8t-5.12-1.728q-3.552 0-5.952 2.304t-2.4 5.856q0 0.8 0.224 1.536t0.48 1.152 0.48 0.832 0.224 0.544q0 0.48-0.256 1.28t-0.672 0.8q-0.032 0-0.288-0.032-0.928-0.288-1.632-0.992t-1.088-1.696-0.576-1.92-0.192-1.92z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Pin</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="https://www.yummly.com/urb/verify?url=https%3A%2F%2Fthewoksoflife.com%2Fpork-ribs-black-bean-sauce%2F&title=Pork%20Ribs%20with%20Black%20Bean%20Sauce&image=https://thewoksoflife.com/wp-content/uploads/2020/05/chinese-ribs-black-bean-sauce-17.jpg" class="dpsp-network-btn dpsp-yummly" target="_blank" title="Share on Yummly"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="49" height="32" viewBox="0 0 49 32"><path d="M4.576 0.128c-0.032 0.032-0.16 0.064-0.32 0.064-0.576 0.096-1.216 0.288-1.376 0.384-0.064 0.064-0.128 0.064-0.16 0.032s-0.032 0-0.032 0.064c0 0.064-0.032 0.064-0.064 0.064-0.096-0.096-1.504 0.672-1.888 1.024-0.16 0.16-0.32 0.288-0.32 0.256s-0.096 0.096-0.192 0.288c-0.16 0.256-0.192 0.416-0.192 0.672 0.032 0.224 0.096 0.448 0.16 0.512 0.032 0.064 0.064 0.096 0.032 0.096-0.096 0 0.064 0.288 0.384 0.768 0.16 0.224 0.32 0.416 0.384 0.416 0.032 0 0.096 0.032 0.064 0.064-0.032 0.128 0.384 0.416 0.576 0.416 0.128 0 0.32-0.128 0.544-0.32 0.16-0.192 0.352-0.32 0.352-0.32 0.032 0 0.192-0.096 0.384-0.224 0.704-0.48 1.6-0.608 1.856-0.288 0.064 0.064 0.16 0.128 0.192 0.096 0.064-0.032 0.064-0.032 0.032 0.032s-0.032 0.192 0 0.288c0.032 0.096 0.032 0.352 0 0.576-0.032 0.192-0.096 0.48-0.096 0.576-0.032 0.128-0.096 0.384-0.16 0.544-0.032 0.192-0.096 0.384-0.096 0.448-0.032 0.032-0.096 0.288-0.16 0.544-0.096 0.256-0.16 0.576-0.192 0.704s-0.064 0.256-0.064 0.288c-0.064 0.064-0.128 0.352-0.16 0.672-0.032 0.064-0.064 0.16-0.064 0.256-0.064 0.16-0.256 0.832-0.288 0.992 0 0.064-0.032 0.192-0.064 0.256-0.064 0.128-0.224 0.8-0.256 0.992-0.032 0.064-0.16 0.576-0.288 1.088-0.16 0.512-0.288 1.024-0.288 1.088-0.032 0.096-0.096 0.288-0.128 0.448-0.064 0.192-0.064 0.352-0.064 0.384 0.032 0.032 0.032 0.096-0.032 0.096-0.096 0.032-0.224 0.96-0.192 1.632 0 0.544 0.32 1.696 0.448 1.696 0.032 0 0.096 0.064 0.128 0.16 0.064 0.224 0.64 0.768 1.024 0.992 0.96 0.544 2.752 0.608 4.512 0.224 0.736-0.16 1.888-0.544 1.92-0.64 0-0.032 0.064-0.064 0.096-0.032 0.064 0.064 1.088-0.448 1.312-0.64 0.064-0.032 0.128-0.064 0.16-0.032 0.032 0-0.032 0.416-0.128 0.864-0.096 0.48-0.16 0.896-0.16 0.928 0 0.064-0.032 0.224-0.16 0.672 0 0.096-0.096 0.16-0.16 0.16-0.576 0-2.688 0.512-2.688 0.608 0 0.064-0.032 0.064-0.096 0.032s-1.184 0.384-1.28 0.512c-0.032 0.032-0.064 0.064-0.064 0s-0.672 0.288-0.768 0.384c0 0.032-0.064 0.096-0.096 0.096-0.16 0-0.704 0.352-0.672 0.416s0.032 0.064-0.032 0.032c-0.16-0.096-1.856 1.664-1.696 1.824 0.032 0.032 0 0.032-0.064 0.032-0.128 0-0.832 1.472-0.96 2.112-0.032 0.096-0.128 0.992-0.16 1.216-0.032 0.544 0.128 1.344 0.384 1.92 0.864 1.824 3.040 2.688 5.44 2.176 0.512-0.128 1.568-0.512 1.696-0.64 0.064-0.064 0.16-0.128 0.16-0.096 0.064 0.032 0.192 0 0.32-0.128 0.096-0.096 0.256-0.224 0.352-0.288 0.192-0.128 0.736-0.64 1.088-1.024 0.32-0.352 0.768-1.024 0.736-1.088-0.032-0.032-0.032-0.064 0.032-0.064s0.352-0.512 0.352-0.608c0-0.032 0.032-0.096 0.064-0.128 0.192-0.128 0.832-1.888 1.088-3.008 0.16-0.64 0.32-1.184 0.352-1.248 0.064-0.16 0.384-0.16 1.984 0.032 0.992 0.128 1.152 0.128 1.344 0.16 0.128 0.032 0.544 0.096 0.96 0.192 1.12 0.16 0.992 0.16 2.88 0.544 0.736 0.128 1.376 0.256 1.472 0.288 0.064 0 0.192 0.032 0.288 0.064 0.064 0.032 0.224 0.064 0.352 0.064 0.192 0.032 0.832 0.16 0.896 0.192 0.032 0 0.16 0.032 0.256 0.064 0.224 0.064 2.432 0.512 2.752 0.608 0.128 0 0.512 0.096 0.864 0.16 0.8 0.16 1.12 0.224 1.376 0.256 0.096 0 0.192 0.032 0.192 0.032 0 0.032 0.064 0.064 0.096 0.064 0.128 0 0.768 0.096 1.024 0.16 0.704 0.128 2.144 0.352 2.528 0.416 0.288 0.032 0.512 0.064 0.544 0.096 0.032 0 0.32 0.032 0.672 0.064 0.32 0.032 0.672 0.064 0.768 0.096 0.704 0.128 5.152 0.224 5.984 0.096 0.224-0.032 0.608-0.064 0.896-0.096s0.544-0.128 0.576-0.16c0.032-0.032 0.064-0.032 0.096-0.032 0.256 0.16 3.616-0.992 3.616-1.216 0-0.032 0.032-0.064 0.064-0.064 0.096 0.032 0.576-0.224 1.024-0.544 0.512-0.384 0.768-0.896 0.768-1.504 0-0.544-0.288-1.248-0.672-1.76-0.288-0.416-0.608-0.736-0.608-0.64 0 0.032-0.032 0-0.096-0.032-0.064-0.064-0.352 0.032-1.056 0.384-0.544 0.256-1.12 0.512-1.28 0.576s-0.416 0.16-0.544 0.224c-0.32 0.16-2.336 0.672-2.816 0.736-0.192 0.032-0.448 0.064-0.544 0.096-0.128 0-0.448 0.032-0.768 0.064-0.288 0.064-0.672 0.096-0.832 0.096-0.448 0.064-3.904 0.064-4.512 0-0.288 0-0.768-0.064-1.056-0.096-0.416-0.032-0.768-0.064-1.664-0.16-0.128 0-0.384-0.032-0.576-0.064-1.152-0.16-1.792-0.256-1.952-0.256-0.128-0.032-0.224-0.032-0.224-0.032 0-0.032-0.16-0.064-0.704-0.128-0.224-0.032-0.48-0.064-0.576-0.096-0.128-0.032-0.448-0.096-0.768-0.128-0.288-0.064-0.64-0.128-0.736-0.128-0.128-0.032-0.32-0.064-0.416-0.064-0.256-0.064-2.048-0.384-2.368-0.448-0.192-0.032-0.736-0.128-1.024-0.16-0.096 0-0.16-0.032-0.16-0.032 0-0.032-0.224-0.064-0.672-0.128-0.192 0-0.416-0.064-0.512-0.064-0.096-0.032-0.32-0.064-0.544-0.096-0.192-0.032-0.448-0.096-0.544-0.096-0.096-0.032-0.32-0.064-0.512-0.064-0.16-0.032-0.384-0.064-0.48-0.064-0.096-0.032-0.416-0.096-0.672-0.128-0.288-0.032-0.576-0.064-0.672-0.064-0.096-0.032-0.384-0.064-0.64-0.096-0.224-0.032-0.544-0.064-0.704-0.064-0.48-0.064-1.568-0.16-1.76-0.16-0.16 0.032-0.16 0-0.064-0.512 0.064-0.288 0.128-0.672 0.16-0.896 0.128-0.768 0.256-1.6 0.32-1.92 0.032-0.096 0.096-0.352 0.096-0.48 0.032-0.16 0.096-0.512 0.128-0.736 0.064-0.224 0.096-0.544 0.128-0.704 0-0.128 0.064-0.32 0.064-0.416 0.032-0.064 0.064-0.288 0.096-0.512 0.032-0.192 0.064-0.416 0.096-0.48 0-0.064 0.032-0.256 0.064-0.416s0.064-0.384 0.096-0.512c0.032-0.192 0.128-0.704 0.16-1.056 0.032-0.128 0.064-0.352 0.16-0.832 0.032-0.096 0.064-0.32 0.096-0.544 0.032-0.192 0.064-0.448 0.096-0.544 0.032-0.224 0.096-0.544 0.16-0.896 0.032-0.128 0.096-0.576 0.16-0.928 0.064-0.384 0.128-0.8 0.16-0.96s0.096-0.576 0.16-0.896c0.096-0.32 0.16-0.768 0.16-0.96 0.032-0.224 0.064-0.416 0.096-0.48 0.032-0.032 0.064-0.224 0.096-0.448 0-0.192 0.064-0.416 0.064-0.48 0.032-0.064 0.064-0.288 0.096-0.48 0-0.192 0.032-0.384 0.064-0.416 0.096-0.128 0.16-1.152 0.096-1.536-0.032-0.224-0.128-0.48-0.192-0.544-0.096-0.096-0.16-0.192-0.128-0.224 0.032 0-0.128-0.128-0.32-0.224-0.672-0.352-2.176-0.288-2.912 0.128-0.256 0.16-0.288 0.192-0.256 0.512 0.064 0.832 0.032 1.728-0.096 2.496-0.096 0.448-0.16 0.896-0.192 0.96 0 0.064-0.032 0.288-0.064 0.448-0.032 0.192-0.096 0.416-0.096 0.512-0.032 0.096-0.064 0.256-0.064 0.384-0.032 0.096-0.064 0.32-0.096 0.48s-0.128 0.8-0.256 1.376c-0.096 0.608-0.224 1.248-0.224 1.408-0.032 0.16-0.096 0.48-0.16 0.736-0.032 0.256-0.096 0.544-0.128 0.672 0 0.128-0.032 0.352-0.064 0.512s-0.16 0.768-0.256 1.376c-0.128 0.608-0.192 1.152-0.192 1.184 0 0.096-0.768 0.544-1.312 0.736-0.192 0.064-0.384 0.16-0.384 0.224s0 0.064-0.032 0.032-0.352 0.064-0.736 0.192c-1.632 0.544-3.008 0.608-3.488 0.128-0.192-0.192-0.192-0.256-0.192-0.928 0-0.736 0.032-0.896 0.992-4.448 0.064-0.256 0.096-0.512 0.064-0.512 0-0.032 0.032-0.096 0.064-0.096 0.032-0.032 0.096-0.16 0.128-0.288 0-0.128 0.032-0.256 0.032-0.256 0.032 0 0.064-0.128 0.128-0.48 0.096-0.48 0.096-0.512 0.128-0.544 0 0 0.032-0.032 0.032-0.064s0.064-0.224 0.128-0.448c0.064-0.192 0.128-0.448 0.128-0.544s0.032-0.224 0.064-0.288c0.48-1.344 0.48-3.2 0-4.256-0.352-0.8-1.216-1.408-2.208-1.6-0.416-0.064-1.696-0.096-1.76-0.032zM10.944 23.968c-0.032 0.192-0.128 0.416-0.16 0.544s-0.064 0.256-0.064 0.288c0 0.064 0 0.096-0.352 0.96-0.128 0.288-0.224 0.576-0.192 0.576 0.032 0.032 0 0.064-0.064 0.064s-0.224 0.32-0.192 0.448c0 0.032 0 0.032-0.032 0.032-0.064-0.032-0.16 0.064-0.224 0.224-0.192 0.288-0.608 0.704-0.832 0.768-0.064 0.032-0.128 0.064-0.128 0.096 0 0.096-0.064 0.096-0.704 0.128-0.544 0.032-0.736-0.064-0.96-0.512-0.16-0.224-0.128-0.992 0.032-1.408 0.064-0.16 0.128-0.352 0.128-0.416s0.032-0.096 0.064-0.064c0.064 0.032 0.096-0.032 0.128-0.128 0.064-0.192 0.832-0.928 0.992-0.928 0.032 0 0.032-0.032 0-0.064-0.032-0.064 0-0.096 0.032-0.096 0.096 0.064 0.704-0.256 0.8-0.384 0.032-0.032 0.064-0.032 0.064 0s0.064 0 0.16-0.032c0.16-0.096 1.28-0.416 1.472-0.416 0.064 0 0.064 0.096 0.032 0.32zM38.848 5.952c-0.16 0.032-0.384 0.064-0.512 0.096-0.288 0.064-1.44 0.48-1.504 0.576-0.032 0.064-0.064 0.064-0.064 0.032s-0.16 0.032-0.352 0.096c-0.32 0.192-0.576 0.224-0.544 0.128 0-0.128-0.128-0.352-0.256-0.352-0.064 0-0.096-0.032-0.096-0.064 0-0.16-0.608-0.352-1.312-0.384-0.48-0.064-2.048 0.384-1.92 0.512 0.032 0 0 0.096-0.032 0.128-0.064 0.096-0.064 0.224 0 0.448 0.096 0.416 0.096 1.248 0 1.632-0.064 0.16-0.096 0.416-0.128 0.64s-0.032 0.384-0.032 0.384c-0.032 0-0.064 0.16-0.128 0.576-0.032 0.16-0.064 0.384-0.096 0.48-0.032 0.128-0.064 0.32-0.064 0.48-0.032 0.16-0.064 0.384-0.096 0.512-0.064 0.224-0.448 2.496-0.512 2.816-0.032 0.256-0.096 0.576-0.192 1.184-0.064 0.256-0.128 0.608-0.128 0.768-0.032 0.128-0.064 0.384-0.096 0.48-0.288 1.6 0.032 2.368 1.056 2.592 0.48 0.128 1.728 0.032 1.888-0.096 0.032-0.032 0.128-0.064 0.224-0.064 0.064 0 0.128-0.032 0.128-0.096 0-0.032 0.032-0.064 0.064-0.064 0.352 0.064 0.448-0.224 0.32-0.8-0.128-0.544-0.096-0.896 0.096-1.856 0.064-0.416 0.16-0.864 0.16-0.992 0.032-0.128 0.064-0.352 0.096-0.448 0.096-0.544 0.128-0.64 0.16-0.896 0.032-0.128 0.064-0.352 0.064-0.48 0.032-0.16 0.064-0.384 0.096-0.512 0.224-1.152 0.288-1.568 0.256-1.632-0.032-0.032-0.032-0.096 0.032-0.128 0.032 0 0.064-0.128 0.064-0.256s0.064-0.48 0.128-0.736l0.096-0.512 0.576-0.256c0.64-0.32 0.992-0.416 1.44-0.32 0.544 0.096 0.704 0.704 0.512 1.824-0.032 0.192-0.096 0.416-0.096 0.512-0.032 0.096-0.064 0.256-0.064 0.384-0.032 0.096-0.064 0.32-0.096 0.48s-0.096 0.608-0.16 1.024c-0.064 0.384-0.16 0.832-0.16 1.024-0.032 0.16-0.064 0.32-0.096 0.384-0.032 0.032-0.064 0.224-0.096 0.48 0 0.224-0.064 0.48-0.096 0.608-0.224 1.152-0.288 2.112-0.16 2.56 0.128 0.32 0.608 0.8 0.736 0.768 0.064-0.032 0.192 0 0.32 0.064 0.256 0.16 1.376 0.096 1.984-0.096 0.576-0.16 0.8-0.384 0.736-0.672-0.032-0.128-0.096-0.32-0.096-0.448-0.032-0.128-0.064-0.256-0.064-0.288-0.032-0.064 0.032-0.512 0.128-1.024 0.064-0.512 0.16-1.056 0.192-1.216s0.096-0.448 0.128-0.704c0.096-0.448 0.16-0.896 0.192-1.152 0.032-0.096 0.096-0.544 0.16-0.96 0.096-0.448 0.16-0.896 0.192-0.992 0-0.128 0.064-0.352 0.064-0.512 0.032-0.16 0.128-0.544 0.16-0.864l0.096-0.576 0.544-0.288c0.768-0.384 1.344-0.48 1.664-0.288 0.16 0.096 0.32 0.288 0.352 0.416 0.096 0.256 0.032 1.088-0.128 1.984-0.064 0.288-0.096 0.448-0.288 1.664-0.224 1.312-0.256 1.472-0.32 1.792 0 0.16-0.032 0.352-0.064 0.416 0 0.064-0.064 0.256-0.064 0.384-0.032 0.16-0.096 0.416-0.096 0.544-0.224 1.216-0.224 1.76 0 2.24 0.128 0.224 0.288 0.352 0.576 0.512 0.384 0.192 0.512 0.192 1.216 0.192 0.608 0 0.896-0.032 1.28-0.192 0.608-0.224 0.672-0.352 0.544-0.928-0.096-0.512-0.032-1.408 0.192-2.464 0.032-0.224 0.096-0.576 0.128-0.736 0.032-0.192 0.096-0.608 0.16-0.928 0.064-0.288 0.096-0.576 0.096-0.608s0-0.064 0.032-0.096c0.032-0.096 0.064-0.288 0.096-0.672 0.032-0.224 0.096-0.448 0.096-0.512 0.032-0.064 0.064-0.256 0.096-0.416 0-0.16 0.064-0.384 0.064-0.448 0.032-0.128 0.064-0.32 0.096-0.48s0.064-0.352 0.064-0.448c0.224-1.088 0.32-2.272 0.192-2.848-0.096-0.512-0.128-0.576-0.256-0.832-0.416-0.8-1.12-1.184-2.432-1.248-0.608-0.032-2.464 0.448-2.464 0.64 0 0.064 0 0.064-0.032 0.032s-0.384 0.128-0.736 0.32l-0.704 0.352-0.16-0.224c-0.224-0.416-0.608-0.736-1.088-0.896-0.48-0.192-1.504-0.288-1.952-0.16zM21.536 6.048c0 0.032-0.224 0.064-0.48 0.064-0.544 0.064-1.184 0.224-1.184 0.352 0 0.032-0.032 0.032-0.064 0.032-0.032-0.032-0.128 0-0.224 0.096-0.128 0.16-0.128 0.192 0.032 0.832 0.064 0.224 0.032 0.864-0.064 1.376-0.064 0.288-0.128 0.608-0.128 0.768 0 0.128-0.064 0.416-0.128 0.64-0.032 0.224-0.096 0.544-0.128 0.704-0.064 0.544-0.096 0.704-0.16 0.864 0 0.064-0.064 0.32-0.064 0.544-0.032 0.224-0.064 0.416-0.096 0.448 0 0.032-0.064 0.224-0.096 0.48-0.032 0.224-0.064 0.48-0.064 0.544-0.032 0.064-0.064 0.256-0.096 0.416-0.096 0.544-0.128 0.8-0.16 1.024-0.16 0.896-0.096 2.208 0.096 2.624 0.064 0.096 0.128 0.256 0.192 0.384 0.16 0.352 0.704 0.896 1.056 1.024 0.928 0.384 1.664 0.416 2.784 0.128 0.224-0.064 0.416-0.128 0.448-0.128 0.064 0 0.16-0.064 0.256-0.096 0.704-0.288 1.472-0.544 1.504-0.512 0 0 0.064 0.128 0.128 0.256 0.288 0.608 0.896 0.864 1.888 0.864 0.64-0.032 1.536-0.256 1.632-0.416 0.032-0.032 0.096-0.064 0.128-0.096 0.032 0 0.064-0.16 0.064-0.384-0.096-1.248-0.096-1.472-0.032-1.76 0.032-0.16 0.096-0.416 0.128-0.576 0.064-0.576 0.128-0.96 0.16-1.12 0.032-0.096 0.064-0.288 0.096-0.448s0.064-0.384 0.096-0.48c0-0.096 0.032-0.288 0.064-0.448s0.096-0.576 0.16-0.896c0.064-0.288 0.128-0.576 0.096-0.608s0-0.096 0.032-0.16c0.032-0.096 0.096-0.32 0.128-0.512 0.032-0.224 0.064-0.48 0.096-0.608 0.032-0.192 0.32-1.792 0.416-2.272 0-0.16 0.064-0.352 0.064-0.48 0.128-0.448 0.064-1.312-0.096-1.632-0.128-0.288-0.736-0.768-0.832-0.672-0.032 0.032-0.096 0-0.16-0.032-0.096-0.096-1.088-0.128-1.44-0.032-0.448 0.096-1.056 0.32-1.184 0.416-0.096 0.096-0.096 0.192-0.032 0.544 0.096 0.448 0.096 1.312 0 1.824-0.032 0.16-0.128 0.576-0.192 0.928-0.064 0.32-0.096 0.64-0.096 0.64 0 0.032 0 0.096 0 0.128-0.032 0.064-0.096 0.352-0.128 0.576-0.032 0.192-0.128 0.704-0.192 1.024-0.032 0.096-0.064 0.32-0.064 0.48-0.032 0.16-0.064 0.32-0.064 0.384-0.032 0.032-0.064 0.256-0.096 0.48-0.064 0.224-0.096 0.448-0.096 0.48 0 0-0.064 0.32-0.128 0.704-0.096 0.576-0.128 0.64-0.352 0.736-0.128 0.064-0.224 0.128-0.192 0.128 0.032 0.032-0.032 0.064-0.096 0.064-0.096 0-0.32 0.064-0.512 0.16-0.864 0.32-1.856 0.064-1.92-0.512 0-0.096-0.032-0.224-0.032-0.288 0-0.16 0.16-1.472 0.192-1.472 0 0 0.032-0.064 0.032-0.16s0.032-0.288 0.064-0.416c0.032-0.128 0.096-0.384 0.096-0.512 0.128-0.704 0.192-1.152 0.256-1.44 0.032-0.128 0.064-0.384 0.096-0.544 0.032-0.192 0.128-0.8 0.256-1.344 0.288-1.632 0.16-2.432-0.416-2.784-0.16-0.064-0.288-0.16-0.352-0.16-0.512-0.096-0.864-0.16-0.896-0.16z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="49" height="32" viewBox="0 0 49 32"><path d="M4.576 0.128c-0.032 0.032-0.16 0.064-0.32 0.064-0.576 0.096-1.216 0.288-1.376 0.384-0.064 0.064-0.128 0.064-0.16 0.032s-0.032 0-0.032 0.064c0 0.064-0.032 0.064-0.064 0.064-0.096-0.096-1.504 0.672-1.888 1.024-0.16 0.16-0.32 0.288-0.32 0.256s-0.096 0.096-0.192 0.288c-0.16 0.256-0.192 0.416-0.192 0.672 0.032 0.224 0.096 0.448 0.16 0.512 0.032 0.064 0.064 0.096 0.032 0.096-0.096 0 0.064 0.288 0.384 0.768 0.16 0.224 0.32 0.416 0.384 0.416 0.032 0 0.096 0.032 0.064 0.064-0.032 0.128 0.384 0.416 0.576 0.416 0.128 0 0.32-0.128 0.544-0.32 0.16-0.192 0.352-0.32 0.352-0.32 0.032 0 0.192-0.096 0.384-0.224 0.704-0.48 1.6-0.608 1.856-0.288 0.064 0.064 0.16 0.128 0.192 0.096 0.064-0.032 0.064-0.032 0.032 0.032s-0.032 0.192 0 0.288c0.032 0.096 0.032 0.352 0 0.576-0.032 0.192-0.096 0.48-0.096 0.576-0.032 0.128-0.096 0.384-0.16 0.544-0.032 0.192-0.096 0.384-0.096 0.448-0.032 0.032-0.096 0.288-0.16 0.544-0.096 0.256-0.16 0.576-0.192 0.704s-0.064 0.256-0.064 0.288c-0.064 0.064-0.128 0.352-0.16 0.672-0.032 0.064-0.064 0.16-0.064 0.256-0.064 0.16-0.256 0.832-0.288 0.992 0 0.064-0.032 0.192-0.064 0.256-0.064 0.128-0.224 0.8-0.256 0.992-0.032 0.064-0.16 0.576-0.288 1.088-0.16 0.512-0.288 1.024-0.288 1.088-0.032 0.096-0.096 0.288-0.128 0.448-0.064 0.192-0.064 0.352-0.064 0.384 0.032 0.032 0.032 0.096-0.032 0.096-0.096 0.032-0.224 0.96-0.192 1.632 0 0.544 0.32 1.696 0.448 1.696 0.032 0 0.096 0.064 0.128 0.16 0.064 0.224 0.64 0.768 1.024 0.992 0.96 0.544 2.752 0.608 4.512 0.224 0.736-0.16 1.888-0.544 1.92-0.64 0-0.032 0.064-0.064 0.096-0.032 0.064 0.064 1.088-0.448 1.312-0.64 0.064-0.032 0.128-0.064 0.16-0.032 0.032 0-0.032 0.416-0.128 0.864-0.096 0.48-0.16 0.896-0.16 0.928 0 0.064-0.032 0.224-0.16 0.672 0 0.096-0.096 0.16-0.16 0.16-0.576 0-2.688 0.512-2.688 0.608 0 0.064-0.032 0.064-0.096 0.032s-1.184 0.384-1.28 0.512c-0.032 0.032-0.064 0.064-0.064 0s-0.672 0.288-0.768 0.384c0 0.032-0.064 0.096-0.096 0.096-0.16 0-0.704 0.352-0.672 0.416s0.032 0.064-0.032 0.032c-0.16-0.096-1.856 1.664-1.696 1.824 0.032 0.032 0 0.032-0.064 0.032-0.128 0-0.832 1.472-0.96 2.112-0.032 0.096-0.128 0.992-0.16 1.216-0.032 0.544 0.128 1.344 0.384 1.92 0.864 1.824 3.040 2.688 5.44 2.176 0.512-0.128 1.568-0.512 1.696-0.64 0.064-0.064 0.16-0.128 0.16-0.096 0.064 0.032 0.192 0 0.32-0.128 0.096-0.096 0.256-0.224 0.352-0.288 0.192-0.128 0.736-0.64 1.088-1.024 0.32-0.352 0.768-1.024 0.736-1.088-0.032-0.032-0.032-0.064 0.032-0.064s0.352-0.512 0.352-0.608c0-0.032 0.032-0.096 0.064-0.128 0.192-0.128 0.832-1.888 1.088-3.008 0.16-0.64 0.32-1.184 0.352-1.248 0.064-0.16 0.384-0.16 1.984 0.032 0.992 0.128 1.152 0.128 1.344 0.16 0.128 0.032 0.544 0.096 0.96 0.192 1.12 0.16 0.992 0.16 2.88 0.544 0.736 0.128 1.376 0.256 1.472 0.288 0.064 0 0.192 0.032 0.288 0.064 0.064 0.032 0.224 0.064 0.352 0.064 0.192 0.032 0.832 0.16 0.896 0.192 0.032 0 0.16 0.032 0.256 0.064 0.224 0.064 2.432 0.512 2.752 0.608 0.128 0 0.512 0.096 0.864 0.16 0.8 0.16 1.12 0.224 1.376 0.256 0.096 0 0.192 0.032 0.192 0.032 0 0.032 0.064 0.064 0.096 0.064 0.128 0 0.768 0.096 1.024 0.16 0.704 0.128 2.144 0.352 2.528 0.416 0.288 0.032 0.512 0.064 0.544 0.096 0.032 0 0.32 0.032 0.672 0.064 0.32 0.032 0.672 0.064 0.768 0.096 0.704 0.128 5.152 0.224 5.984 0.096 0.224-0.032 0.608-0.064 0.896-0.096s0.544-0.128 0.576-0.16c0.032-0.032 0.064-0.032 0.096-0.032 0.256 0.16 3.616-0.992 3.616-1.216 0-0.032 0.032-0.064 0.064-0.064 0.096 0.032 0.576-0.224 1.024-0.544 0.512-0.384 0.768-0.896 0.768-1.504 0-0.544-0.288-1.248-0.672-1.76-0.288-0.416-0.608-0.736-0.608-0.64 0 0.032-0.032 0-0.096-0.032-0.064-0.064-0.352 0.032-1.056 0.384-0.544 0.256-1.12 0.512-1.28 0.576s-0.416 0.16-0.544 0.224c-0.32 0.16-2.336 0.672-2.816 0.736-0.192 0.032-0.448 0.064-0.544 0.096-0.128 0-0.448 0.032-0.768 0.064-0.288 0.064-0.672 0.096-0.832 0.096-0.448 0.064-3.904 0.064-4.512 0-0.288 0-0.768-0.064-1.056-0.096-0.416-0.032-0.768-0.064-1.664-0.16-0.128 0-0.384-0.032-0.576-0.064-1.152-0.16-1.792-0.256-1.952-0.256-0.128-0.032-0.224-0.032-0.224-0.032 0-0.032-0.16-0.064-0.704-0.128-0.224-0.032-0.48-0.064-0.576-0.096-0.128-0.032-0.448-0.096-0.768-0.128-0.288-0.064-0.64-0.128-0.736-0.128-0.128-0.032-0.32-0.064-0.416-0.064-0.256-0.064-2.048-0.384-2.368-0.448-0.192-0.032-0.736-0.128-1.024-0.16-0.096 0-0.16-0.032-0.16-0.032 0-0.032-0.224-0.064-0.672-0.128-0.192 0-0.416-0.064-0.512-0.064-0.096-0.032-0.32-0.064-0.544-0.096-0.192-0.032-0.448-0.096-0.544-0.096-0.096-0.032-0.32-0.064-0.512-0.064-0.16-0.032-0.384-0.064-0.48-0.064-0.096-0.032-0.416-0.096-0.672-0.128-0.288-0.032-0.576-0.064-0.672-0.064-0.096-0.032-0.384-0.064-0.64-0.096-0.224-0.032-0.544-0.064-0.704-0.064-0.48-0.064-1.568-0.16-1.76-0.16-0.16 0.032-0.16 0-0.064-0.512 0.064-0.288 0.128-0.672 0.16-0.896 0.128-0.768 0.256-1.6 0.32-1.92 0.032-0.096 0.096-0.352 0.096-0.48 0.032-0.16 0.096-0.512 0.128-0.736 0.064-0.224 0.096-0.544 0.128-0.704 0-0.128 0.064-0.32 0.064-0.416 0.032-0.064 0.064-0.288 0.096-0.512 0.032-0.192 0.064-0.416 0.096-0.48 0-0.064 0.032-0.256 0.064-0.416s0.064-0.384 0.096-0.512c0.032-0.192 0.128-0.704 0.16-1.056 0.032-0.128 0.064-0.352 0.16-0.832 0.032-0.096 0.064-0.32 0.096-0.544 0.032-0.192 0.064-0.448 0.096-0.544 0.032-0.224 0.096-0.544 0.16-0.896 0.032-0.128 0.096-0.576 0.16-0.928 0.064-0.384 0.128-0.8 0.16-0.96s0.096-0.576 0.16-0.896c0.096-0.32 0.16-0.768 0.16-0.96 0.032-0.224 0.064-0.416 0.096-0.48 0.032-0.032 0.064-0.224 0.096-0.448 0-0.192 0.064-0.416 0.064-0.48 0.032-0.064 0.064-0.288 0.096-0.48 0-0.192 0.032-0.384 0.064-0.416 0.096-0.128 0.16-1.152 0.096-1.536-0.032-0.224-0.128-0.48-0.192-0.544-0.096-0.096-0.16-0.192-0.128-0.224 0.032 0-0.128-0.128-0.32-0.224-0.672-0.352-2.176-0.288-2.912 0.128-0.256 0.16-0.288 0.192-0.256 0.512 0.064 0.832 0.032 1.728-0.096 2.496-0.096 0.448-0.16 0.896-0.192 0.96 0 0.064-0.032 0.288-0.064 0.448-0.032 0.192-0.096 0.416-0.096 0.512-0.032 0.096-0.064 0.256-0.064 0.384-0.032 0.096-0.064 0.32-0.096 0.48s-0.128 0.8-0.256 1.376c-0.096 0.608-0.224 1.248-0.224 1.408-0.032 0.16-0.096 0.48-0.16 0.736-0.032 0.256-0.096 0.544-0.128 0.672 0 0.128-0.032 0.352-0.064 0.512s-0.16 0.768-0.256 1.376c-0.128 0.608-0.192 1.152-0.192 1.184 0 0.096-0.768 0.544-1.312 0.736-0.192 0.064-0.384 0.16-0.384 0.224s0 0.064-0.032 0.032-0.352 0.064-0.736 0.192c-1.632 0.544-3.008 0.608-3.488 0.128-0.192-0.192-0.192-0.256-0.192-0.928 0-0.736 0.032-0.896 0.992-4.448 0.064-0.256 0.096-0.512 0.064-0.512 0-0.032 0.032-0.096 0.064-0.096 0.032-0.032 0.096-0.16 0.128-0.288 0-0.128 0.032-0.256 0.032-0.256 0.032 0 0.064-0.128 0.128-0.48 0.096-0.48 0.096-0.512 0.128-0.544 0 0 0.032-0.032 0.032-0.064s0.064-0.224 0.128-0.448c0.064-0.192 0.128-0.448 0.128-0.544s0.032-0.224 0.064-0.288c0.48-1.344 0.48-3.2 0-4.256-0.352-0.8-1.216-1.408-2.208-1.6-0.416-0.064-1.696-0.096-1.76-0.032zM10.944 23.968c-0.032 0.192-0.128 0.416-0.16 0.544s-0.064 0.256-0.064 0.288c0 0.064 0 0.096-0.352 0.96-0.128 0.288-0.224 0.576-0.192 0.576 0.032 0.032 0 0.064-0.064 0.064s-0.224 0.32-0.192 0.448c0 0.032 0 0.032-0.032 0.032-0.064-0.032-0.16 0.064-0.224 0.224-0.192 0.288-0.608 0.704-0.832 0.768-0.064 0.032-0.128 0.064-0.128 0.096 0 0.096-0.064 0.096-0.704 0.128-0.544 0.032-0.736-0.064-0.96-0.512-0.16-0.224-0.128-0.992 0.032-1.408 0.064-0.16 0.128-0.352 0.128-0.416s0.032-0.096 0.064-0.064c0.064 0.032 0.096-0.032 0.128-0.128 0.064-0.192 0.832-0.928 0.992-0.928 0.032 0 0.032-0.032 0-0.064-0.032-0.064 0-0.096 0.032-0.096 0.096 0.064 0.704-0.256 0.8-0.384 0.032-0.032 0.064-0.032 0.064 0s0.064 0 0.16-0.032c0.16-0.096 1.28-0.416 1.472-0.416 0.064 0 0.064 0.096 0.032 0.32zM38.848 5.952c-0.16 0.032-0.384 0.064-0.512 0.096-0.288 0.064-1.44 0.48-1.504 0.576-0.032 0.064-0.064 0.064-0.064 0.032s-0.16 0.032-0.352 0.096c-0.32 0.192-0.576 0.224-0.544 0.128 0-0.128-0.128-0.352-0.256-0.352-0.064 0-0.096-0.032-0.096-0.064 0-0.16-0.608-0.352-1.312-0.384-0.48-0.064-2.048 0.384-1.92 0.512 0.032 0 0 0.096-0.032 0.128-0.064 0.096-0.064 0.224 0 0.448 0.096 0.416 0.096 1.248 0 1.632-0.064 0.16-0.096 0.416-0.128 0.64s-0.032 0.384-0.032 0.384c-0.032 0-0.064 0.16-0.128 0.576-0.032 0.16-0.064 0.384-0.096 0.48-0.032 0.128-0.064 0.32-0.064 0.48-0.032 0.16-0.064 0.384-0.096 0.512-0.064 0.224-0.448 2.496-0.512 2.816-0.032 0.256-0.096 0.576-0.192 1.184-0.064 0.256-0.128 0.608-0.128 0.768-0.032 0.128-0.064 0.384-0.096 0.48-0.288 1.6 0.032 2.368 1.056 2.592 0.48 0.128 1.728 0.032 1.888-0.096 0.032-0.032 0.128-0.064 0.224-0.064 0.064 0 0.128-0.032 0.128-0.096 0-0.032 0.032-0.064 0.064-0.064 0.352 0.064 0.448-0.224 0.32-0.8-0.128-0.544-0.096-0.896 0.096-1.856 0.064-0.416 0.16-0.864 0.16-0.992 0.032-0.128 0.064-0.352 0.096-0.448 0.096-0.544 0.128-0.64 0.16-0.896 0.032-0.128 0.064-0.352 0.064-0.48 0.032-0.16 0.064-0.384 0.096-0.512 0.224-1.152 0.288-1.568 0.256-1.632-0.032-0.032-0.032-0.096 0.032-0.128 0.032 0 0.064-0.128 0.064-0.256s0.064-0.48 0.128-0.736l0.096-0.512 0.576-0.256c0.64-0.32 0.992-0.416 1.44-0.32 0.544 0.096 0.704 0.704 0.512 1.824-0.032 0.192-0.096 0.416-0.096 0.512-0.032 0.096-0.064 0.256-0.064 0.384-0.032 0.096-0.064 0.32-0.096 0.48s-0.096 0.608-0.16 1.024c-0.064 0.384-0.16 0.832-0.16 1.024-0.032 0.16-0.064 0.32-0.096 0.384-0.032 0.032-0.064 0.224-0.096 0.48 0 0.224-0.064 0.48-0.096 0.608-0.224 1.152-0.288 2.112-0.16 2.56 0.128 0.32 0.608 0.8 0.736 0.768 0.064-0.032 0.192 0 0.32 0.064 0.256 0.16 1.376 0.096 1.984-0.096 0.576-0.16 0.8-0.384 0.736-0.672-0.032-0.128-0.096-0.32-0.096-0.448-0.032-0.128-0.064-0.256-0.064-0.288-0.032-0.064 0.032-0.512 0.128-1.024 0.064-0.512 0.16-1.056 0.192-1.216s0.096-0.448 0.128-0.704c0.096-0.448 0.16-0.896 0.192-1.152 0.032-0.096 0.096-0.544 0.16-0.96 0.096-0.448 0.16-0.896 0.192-0.992 0-0.128 0.064-0.352 0.064-0.512 0.032-0.16 0.128-0.544 0.16-0.864l0.096-0.576 0.544-0.288c0.768-0.384 1.344-0.48 1.664-0.288 0.16 0.096 0.32 0.288 0.352 0.416 0.096 0.256 0.032 1.088-0.128 1.984-0.064 0.288-0.096 0.448-0.288 1.664-0.224 1.312-0.256 1.472-0.32 1.792 0 0.16-0.032 0.352-0.064 0.416 0 0.064-0.064 0.256-0.064 0.384-0.032 0.16-0.096 0.416-0.096 0.544-0.224 1.216-0.224 1.76 0 2.24 0.128 0.224 0.288 0.352 0.576 0.512 0.384 0.192 0.512 0.192 1.216 0.192 0.608 0 0.896-0.032 1.28-0.192 0.608-0.224 0.672-0.352 0.544-0.928-0.096-0.512-0.032-1.408 0.192-2.464 0.032-0.224 0.096-0.576 0.128-0.736 0.032-0.192 0.096-0.608 0.16-0.928 0.064-0.288 0.096-0.576 0.096-0.608s0-0.064 0.032-0.096c0.032-0.096 0.064-0.288 0.096-0.672 0.032-0.224 0.096-0.448 0.096-0.512 0.032-0.064 0.064-0.256 0.096-0.416 0-0.16 0.064-0.384 0.064-0.448 0.032-0.128 0.064-0.32 0.096-0.48s0.064-0.352 0.064-0.448c0.224-1.088 0.32-2.272 0.192-2.848-0.096-0.512-0.128-0.576-0.256-0.832-0.416-0.8-1.12-1.184-2.432-1.248-0.608-0.032-2.464 0.448-2.464 0.64 0 0.064 0 0.064-0.032 0.032s-0.384 0.128-0.736 0.32l-0.704 0.352-0.16-0.224c-0.224-0.416-0.608-0.736-1.088-0.896-0.48-0.192-1.504-0.288-1.952-0.16zM21.536 6.048c0 0.032-0.224 0.064-0.48 0.064-0.544 0.064-1.184 0.224-1.184 0.352 0 0.032-0.032 0.032-0.064 0.032-0.032-0.032-0.128 0-0.224 0.096-0.128 0.16-0.128 0.192 0.032 0.832 0.064 0.224 0.032 0.864-0.064 1.376-0.064 0.288-0.128 0.608-0.128 0.768 0 0.128-0.064 0.416-0.128 0.64-0.032 0.224-0.096 0.544-0.128 0.704-0.064 0.544-0.096 0.704-0.16 0.864 0 0.064-0.064 0.32-0.064 0.544-0.032 0.224-0.064 0.416-0.096 0.448 0 0.032-0.064 0.224-0.096 0.48-0.032 0.224-0.064 0.48-0.064 0.544-0.032 0.064-0.064 0.256-0.096 0.416-0.096 0.544-0.128 0.8-0.16 1.024-0.16 0.896-0.096 2.208 0.096 2.624 0.064 0.096 0.128 0.256 0.192 0.384 0.16 0.352 0.704 0.896 1.056 1.024 0.928 0.384 1.664 0.416 2.784 0.128 0.224-0.064 0.416-0.128 0.448-0.128 0.064 0 0.16-0.064 0.256-0.096 0.704-0.288 1.472-0.544 1.504-0.512 0 0 0.064 0.128 0.128 0.256 0.288 0.608 0.896 0.864 1.888 0.864 0.64-0.032 1.536-0.256 1.632-0.416 0.032-0.032 0.096-0.064 0.128-0.096 0.032 0 0.064-0.16 0.064-0.384-0.096-1.248-0.096-1.472-0.032-1.76 0.032-0.16 0.096-0.416 0.128-0.576 0.064-0.576 0.128-0.96 0.16-1.12 0.032-0.096 0.064-0.288 0.096-0.448s0.064-0.384 0.096-0.48c0-0.096 0.032-0.288 0.064-0.448s0.096-0.576 0.16-0.896c0.064-0.288 0.128-0.576 0.096-0.608s0-0.096 0.032-0.16c0.032-0.096 0.096-0.32 0.128-0.512 0.032-0.224 0.064-0.48 0.096-0.608 0.032-0.192 0.32-1.792 0.416-2.272 0-0.16 0.064-0.352 0.064-0.48 0.128-0.448 0.064-1.312-0.096-1.632-0.128-0.288-0.736-0.768-0.832-0.672-0.032 0.032-0.096 0-0.16-0.032-0.096-0.096-1.088-0.128-1.44-0.032-0.448 0.096-1.056 0.32-1.184 0.416-0.096 0.096-0.096 0.192-0.032 0.544 0.096 0.448 0.096 1.312 0 1.824-0.032 0.16-0.128 0.576-0.192 0.928-0.064 0.32-0.096 0.64-0.096 0.64 0 0.032 0 0.096 0 0.128-0.032 0.064-0.096 0.352-0.128 0.576-0.032 0.192-0.128 0.704-0.192 1.024-0.032 0.096-0.064 0.32-0.064 0.48-0.032 0.16-0.064 0.32-0.064 0.384-0.032 0.032-0.064 0.256-0.096 0.48-0.064 0.224-0.096 0.448-0.096 0.48 0 0-0.064 0.32-0.128 0.704-0.096 0.576-0.128 0.64-0.352 0.736-0.128 0.064-0.224 0.128-0.192 0.128 0.032 0.032-0.032 0.064-0.096 0.064-0.096 0-0.32 0.064-0.512 0.16-0.864 0.32-1.856 0.064-1.92-0.512 0-0.096-0.032-0.224-0.032-0.288 0-0.16 0.16-1.472 0.192-1.472 0 0 0.032-0.064 0.032-0.16s0.032-0.288 0.064-0.416c0.032-0.128 0.096-0.384 0.096-0.512 0.128-0.704 0.192-1.152 0.256-1.44 0.032-0.128 0.064-0.384 0.096-0.544 0.032-0.192 0.128-0.8 0.256-1.344 0.288-1.632 0.16-2.432-0.416-2.784-0.16-0.064-0.288-0.16-0.352-0.16-0.512-0.096-0.864-0.16-0.896-0.16z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Save</span></span></a></li><li><a rel="nofollow noopener noreferrer" href="/cdn-cgi/l/email-protection#97a8e4e2f5fdf2f4e3aac7f8e5fcb2a5a7c5fef5e4b2a5a7e0fee3ffb2a5a7d5fbf6f4fcb2a5a7d5f2f6f9b2a5a7c4f6e2f4f2b1f6fae7acf5f8f3eeaaffe3e3e7e4b2a4d6b2a5d1b2a5d1e3fff2e0f8fce4f8f1fbfef1f2b9f4f8fab2a5d1e7f8e5fcbae5fef5e4baf5fbf6f4fcbaf5f2f6f9bae4f6e2f4f2b2a5d1" class="dpsp-network-btn dpsp-email dpsp-no-label dpsp-last" target="_blank" title="Send over email"><span class="dpsp-network-icon"><span class="dpsp-network-icon-before"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="32" viewBox="0 0 28 32"><path d="M18.56 17.408l8.256 8.544h-25.248l8.288-8.448 4.32 4.064zM2.016 6.048h24.32l-12.16 11.584zM20.128 15.936l8.224-7.744v16.256zM0 24.448v-16.256l8.288 7.776z"></path></svg></span><span class="dpsp-network-icon-after"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="32" viewBox="0 0 28 32"><path d="M18.56 17.408l8.256 8.544h-25.248l8.288-8.448 4.32 4.064zM2.016 6.048h24.32l-12.16 11.584zM20.128 15.936l8.224-7.744v16.256zM0 24.448v-16.256l8.288 7.776z"></path></svg></span></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label"></span></span></a></li></ul></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://thewoksoflife.com/category/recipes/main-dishes/" rel="category tag">Main Dishes</a>, <a href="https://thewoksoflife.com/category/recipes/pork/" rel="category tag">Pork</a>, <a href="https://thewoksoflife.com/category/recipes/" rel="category tag">Recipes</a></span></p></footer></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/pork-ribs-black-bean-sauce/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://thewoksoflife.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-wprm-rating" data-color="#fecd00"> <label for="wprm-rating">Recipe Rating</label> <span class="wprm-rating-stars"> <span class="wprm-rating-star" data-rating="1" onmouseenter="WPRecipeMaker.rating.onMouseEnter(this)" onmouseleave="WPRecipeMaker.rating.onMouseLeave(this)" onclick="WPRecipeMaker.rating.onClick(this)"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><span class="wprm-rating-star" data-rating="2" onmouseenter="WPRecipeMaker.rating.onMouseEnter(this)" onmouseleave="WPRecipeMaker.rating.onMouseLeave(this)" onclick="WPRecipeMaker.rating.onClick(this)"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><span class="wprm-rating-star" data-rating="3" onmouseenter="WPRecipeMaker.rating.onMouseEnter(this)" onmouseleave="WPRecipeMaker.rating.onMouseLeave(this)" onclick="WPRecipeMaker.rating.onClick(this)"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><span class="wprm-rating-star" data-rating="4" onmouseenter="WPRecipeMaker.rating.onMouseEnter(this)" onmouseleave="WPRecipeMaker.rating.onMouseLeave(this)" onclick="WPRecipeMaker.rating.onClick(this)"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span><span class="wprm-rating-star" data-rating="5" onmouseenter="WPRecipeMaker.rating.onMouseEnter(this)" onmouseleave="WPRecipeMaker.rating.onMouseLeave(this)" onclick="WPRecipeMaker.rating.onClick(this)"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="16px" height="16px" viewBox="0 0 24 24"><g transform="translate(0, 0)"><polygon fill="none" stroke="#343434" stroke-width="2" stroke-linecap="square" stroke-miterlimit="10" points="12,2.6 15,9 21.4,9 16.7,13.9 18.6,21.4 12,17.6 5.4,21.4 7.3,13.9 2.6,9 9,9 " stroke-linejoin="miter" /></g></svg></span> </span> <input id="wprm-comment-rating" name="wprm-comment-rating" type="hidden" value="0"></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='39997' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="31752d0a74" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="166" /></p></form></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p><div class="entry-comments" id="comments"><h3>9 Comments</h3><ol class="comment-list"><li class="comment even thread-even depth-1" id="comment-343034"><article id="article-comment-343034"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name">Agnes Ma</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-343034">June 2, 2020 at 12:29 AM</a></time></p></header><div class="comment-content"><p>Hi, Bill; I have 3 questions below:<br /> 1. What burner setting to use to heat the water to boil? (high or medium?)<br /> 2. Once the water is boiling, add in the ribs. Do I still keep the heat on as before (high or medium)? or reduce to low heat?<br /> 3. Do I keep the lid on during this 40 minutes simmering period?</p><p>Thanks in advance for your time. I am waiting for your answer.</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-343034' data-commentid="343034" data-postid="39997" data-belowelement="article-comment-343034" data-respondelement="respond" aria-label='Reply to Agnes Ma'>Reply</a></div></article></li><li class="comment odd alt thread-odd thread-alt depth-1" id="comment-342982"><article id="article-comment-342982"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name">amii</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-342982">June 1, 2020 at 6:49 PM</a></time></p></header><div class="comment-content"><p>I love the idea of freezing portions of the pre-cooked ribs and using it whenever I get an urge for this dish. Should I freeze each portion in some of the pork broth to be able to make the future sauce? What can I substitute later for the pork broth when cooking the frozen pre-cooked ribs if I want more sauce? Thank you for the recipe. The steamed version is delicious and this one looks even better.</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-342982' data-commentid="342982" data-postid="39997" data-belowelement="article-comment-342982" data-respondelement="respond" aria-label='Reply to amii'>Reply</a></div></article></li><li class="comment even thread-even depth-1" id="comment-342937"><article id="article-comment-342937"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name">D Noble</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-342937">June 1, 2020 at 3:28 PM</a></time></p></header><div class="comment-content"><p>Ive just started working with black beans and realy appreciate this recipe.</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-342937' data-commentid="342937" data-postid="39997" data-belowelement="article-comment-342937" data-respondelement="respond" aria-label='Reply to D Noble'>Reply</a></div></article></li><li class="comment odd alt thread-odd thread-alt depth-1" id="comment-342927"><article id="article-comment-342927"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name">JOHN MARK</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-342927">June 1, 2020 at 2:42 PM</a></time></p></header><div class="comment-content"><p><img class="wprm-comment-rating" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2016'%3E%3C/svg%3E" alt="5 stars" width="80" height="16" data-lazy-src="https://thewoksoflife.com/wp-content/plugins/wp-recipe-maker/assets/icons/rating/stars-5.svg" /><noscript><img class="wprm-comment-rating" src="https://thewoksoflife.com/wp-content/plugins/wp-recipe-maker/assets/icons/rating/stars-5.svg" alt="5 stars" width="80" height="16" /></noscript><br /> My father was in the Chinese restaurant business from the 1930s to 70s in New York. Spare ribs with black bean sauce is a favorite and I usually prepare it with Bitter Melon or Gai Choy. Try adding it to your recipe, I think you&#8217;ll like it.</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-342927' data-commentid="342927" data-postid="39997" data-belowelement="article-comment-342927" data-respondelement="respond" aria-label='Reply to JOHN MARK'>Reply</a></div></article></li><li class="comment even thread-even depth-1" id="comment-342916"><article id="article-comment-342916"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name">Robert Prinzing</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-342916">June 1, 2020 at 1:59 PM</a></time></p></header><div class="comment-content"><p>Hi this sounds great. One question about the beans. You say they come in a bag, so I assume they are dry. Do you put dried beans into the recipe, or do you reconstitute them?</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-342916' data-commentid="342916" data-postid="39997" data-belowelement="article-comment-342916" data-respondelement="respond" aria-label='Reply to Robert Prinzing'>Reply</a></div></article></li><li class="comment odd alt thread-odd thread-alt depth-1" id="comment-342877"><article id="article-comment-342877"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name">Vicki</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-342877">June 1, 2020 at 11:20 AM</a></time></p></header><div class="comment-content"><p>Can I make this without chopping up the bones?</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-342877' data-commentid="342877" data-postid="39997" data-belowelement="article-comment-342877" data-respondelement="respond" aria-label='Reply to Vicki'>Reply</a></div></article><ul class="children"><li class="comment byuser comment-author-sarahleung838gmail-com even depth-2" id="comment-343169"><article id="article-comment-343169"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name"><a href="https://www.thewoksoflife.com" class="comment-author-link" rel="external nofollow">Sarah</a></span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-343169">June 2, 2020 at 11:47 AM</a></time></p></header><div class="comment-content"><p>Hi Vicki, you can use boneless country ribs to make this! No bones to mess with! The ribs should be cut into smaller pieces––wouldn&#8217;t recommend using whole ribs to make this.</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-343169' data-commentid="343169" data-postid="39997" data-belowelement="article-comment-343169" data-respondelement="respond" aria-label='Reply to Sarah'>Reply</a></div></article></li></ul></li><li class="comment odd alt thread-even depth-1" id="comment-342873"><article id="article-comment-342873"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name">Cynthia Bunten</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-342873">June 1, 2020 at 11:13 AM</a></time></p></header><div class="comment-content"><p>I LOVE these but usually use my mom&#8217;s recipe. I always order them when I&#8217;m lucky enough to go somewhere for Dim Sum. When I make them at home I leave out the onions and green pepper but always keep the green onion! It is hard to find riblets these days. I have a good cleaver but cutting up ribs makes me nervous. I will definitely try pre-boiling them first next time. What a time saver! Tried making them in my Instant Pot but they just weren&#8217;t the same. Thank you!</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-342873' data-commentid="342873" data-postid="39997" data-belowelement="article-comment-342873" data-respondelement="respond" aria-label='Reply to Cynthia Bunten'>Reply</a></div></article></li><li class="comment even thread-odd thread-alt depth-1" id="comment-342867"><article id="article-comment-342867"><header class="comment-header"><p class="comment-author"> <span class="comment-author-name">Lynn</span> <span class="says">says</span></p><p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://thewoksoflife.com/pork-ribs-black-bean-sauce/#comment-342867">June 1, 2020 at 10:34 AM</a></time></p></header><div class="comment-content"><p>I really like your tip on boiling the ribs first and then cook them as you need. That makes it much easier to make a weekday dinner. Thanks!</p></div><div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-342867' data-commentid="342867" data-postid="39997" data-belowelement="article-comment-342867" data-respondelement="respond" aria-label='Reply to Lynn'>Reply</a></div></article></li></ol></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><section id="text-15" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Welcome!</h4><div class="textwidget"><p><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" nopin="nopin" width="150" height="150" class="alignleft" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2014/06/twol-icon.jpeg"><noscript><img src="https://thewoksoflife.com/wp-content/uploads/2014/06/twol-icon.jpeg" nopin="nopin" width="150" height="150" class="alignleft"></noscript>We're Bill, Judy, Sarah, and Kaitlin––a family of four cooks sharing our home-cooked and restaurant-style recipes. <a href="https://thewoksoflife.com/about/">Get our full story here</a>.</p></div></div></section><section id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><div class="widget-wrap"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-12107 mc4wp-form-basic" method="post" data-id="12107" data-name="Default sign-up form"><div class="mc4wp-form-fields"><div class="signup-sidebar"><h4 class="widget-title"> Sign Up For Email Updates (And Get Our Top 25 Recipes eBook!)</h4><p> <input type="text" name="FNAME" placeholder="First Name" required=""></p><p> <input type="email" id="mc4wp_email" name="EMAIL" placeholder="Your email address" required /><input type="submit" value="GO" /></p></div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1591124364" /><input type="hidden" name="_mc4wp_form_id" value="12107" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></div></section><section id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us:</h4><ul class="aligncenter"><li class="ssi-facebook"><a href="https://www.facebook.com/thewoksoflife?ref=hl" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-facebook" aria-labelledby="social-facebook-2"><title id="social-facebook-2">Facebook</title><use xlink:href="https://thewoksoflife.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-instagram"><a href="https://instagram.com/thewoksoflife" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-instagram" aria-labelledby="social-instagram-2"><title id="social-instagram-2">Instagram</title><use xlink:href="https://thewoksoflife.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-instagram"></use></svg></a></li><li class="ssi-pinterest"><a href="https://www.pinterest.com/thewoksoflife1/" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-pinterest" aria-labelledby="social-pinterest-2"><title id="social-pinterest-2">Pinterest</title><use xlink:href="https://thewoksoflife.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-pinterest"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/thewoksoflife" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-2"><title id="social-twitter-2">Twitter</title><use xlink:href="https://thewoksoflife.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section><section id="text-79" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Learn about Essential Chinese Cooking Tools for your Kitchen</h4><div class="textwidget"><a href="https://thewoksoflife.com/how-to/chinese-cooking-tools/" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20300'%3E%3C/svg%3E" nopin="nopin" width="300" height="300" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2015/11/Chinese-cooking-tools-300sq.jpg" /><noscript><img src="https://thewoksoflife.com/wp-content/uploads/2015/11/Chinese-cooking-tools-300sq.jpg" nopin = "nopin" width="300" height="300"/></noscript></a></div></div></section><section id="text-81" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">How The Woks of Life Got Started &#038; How to Start a Blog</h4><div class="textwidget"><a href="https://thewoksoflife.com/2018/11/starting-food-blog-website/" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20250%20250'%3E%3C/svg%3E" nopin="nopin" width="250" height="250" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/11/H2SB-250x250-.png" /><noscript><img src="https://thewoksoflife.com/wp-content/uploads/2018/11/H2SB-250x250-.png" nopin = "nopin" width="250" height="250"/></noscript></a></div></div></section><section id="text-80" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Learn All About Chinese Preserved Meats, Seafood, and Vegetables</h4><div class="textwidget"><a href="https://thewoksoflife.com/chinese-dried-preserved-ingredients/" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20300'%3E%3C/svg%3E" nopin="nopin" width="300" height="300" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/01/chinese-dried-preserved-ingredients-300.jpg" /><noscript><img src="https://thewoksoflife.com/wp-content/uploads/2018/01/chinese-dried-preserved-ingredients-300.jpg" nopin = "nopin" width="300" height="300"/></noscript></a></div></div></section></aside></div></div><div class="before-footer-widgets"><div class="wrap"><section id="text-96" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><h4 class="widget-title widgettitle"><a href="https://thewoksoflife.com/category/recipes/vegetables/">Make Our Favorite Vegetable Dishes</a>!<a href="/category/recipes/chinese-new-year/"><span class="alignright">See All</span></a></h4></div></div></section><section id="featured-post-2" class="widget featured-content featuredpost"><div class="widget-wrap"><article class="post-7288 post type-post status-publish format-standard has-post-thumbnail category-recipes category-side-dishes category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/sichuan-dry-fried-green-beans/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Sichuan Dry Fried Green Beans, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2014/11/dry-fried-string-beans-10-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2014/11/dry-fried-string-beans-10-300x400.jpg" class="entry-image attachment-post" alt="Sichuan Dry Fried Green Beans, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/sichuan-dry-fried-green-beans/">Sichuan Dry Fried Green Beans</a></h2></header></article><article class="post-18764 post type-post status-publish format-standard has-post-thumbnail category-main-dishes category-recipes category-tofu category-vegetarian category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/vegetable-moo-shu/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Vegetable Moo Shu, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2017/08/vegetable-mooshu-11-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2017/08/vegetable-mooshu-11-300x400.jpg" class="entry-image attachment-post" alt="Vegetable Moo Shu, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/vegetable-moo-shu/">Vegetable Moo Shu with Mandarin Pancakes</a></h2></header></article><article class="post-23782 post type-post status-publish format-standard has-post-thumbnail category-recipes category-side-dishes category-vegetarian category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/boiled-daikon-radish/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Boiled Daikon, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2019/01/boiled-daikon-6-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2019/01/boiled-daikon-6-300x400.jpg" class="entry-image attachment-post" alt="Boiled Daikon, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/boiled-daikon-radish/">Boiled Daikon Radish</a></h2></header></article><article class="post-7835 post type-post status-publish format-standard has-post-thumbnail category-appetizers-and-snacks category-chinese-new-year category-dim-sum category-recipes category-vegetables course-appetizers-and-snacks cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/taro-cake-wu-tao-gou/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Crispy Taro Cake, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2015/01/taro-cake-10-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2015/01/taro-cake-10-300x400.jpg" class="entry-image attachment-post" alt="Crispy Taro Cake, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/taro-cake-wu-tao-gou/">Taro Cake (Chinese Wu Tao Gou)</a></h2></header></article><article class="post-23758 post type-post status-publish format-standard has-post-thumbnail category-recipes category-vegetarian category-vegetables course-vegetables archive-single entry"><a href="https://thewoksoflife.com/roasted-chickpeas-recipe/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Roasted Chickpeas, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2019/01/roasted-chickpeas-2-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2019/01/roasted-chickpeas-2-300x400.jpg" class="entry-image attachment-post" alt="Roasted Chickpeas, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/roasted-chickpeas-recipe/">Roasted Chickpeas: A Versatile Recipe for Soups, Salads, &#038; Pastas</a></h2></header></article><article class="post-23560 post type-post status-publish format-standard has-post-thumbnail category-appetizers-and-snacks category-party-food category-recipes category-vegetarian category-vegetables course-appetizer cuisine-american archive-single entry"><a href="https://thewoksoflife.com/classic-easy-stuffed-mushrooms/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Classic, Easy Stuffed Mushrooms, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/11/stuffed-mushrooms-2-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2018/11/stuffed-mushrooms-2-300x400.jpg" class="entry-image attachment-post" alt="Classic, Easy Stuffed Mushrooms, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/classic-easy-stuffed-mushrooms/">Classic, Easy Stuffed Mushrooms</a></h2></header></article><article class="post-33203 post type-post status-publish format-standard has-post-thumbnail category-appetizers-and-snacks category-quick-and-easy category-recipes category-steamed-dishes category-vegetarian category-vegetables archive-single entry"><a href="https://thewoksoflife.com/steamed-chinese-eggplant-spicy/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Chinese Steamed Eggplant, thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2019/08/chinese-steamed-eggplant-11-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2019/08/chinese-steamed-eggplant-11-300x400.jpg" class="entry-image attachment-post" alt="Chinese Steamed Eggplant, thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/steamed-chinese-eggplant-spicy/">Steamed Chinese Eggplant with Spicy Lao Gan Ma</a></h2></header></article><article class="post-11448 post type-post status-publish format-standard has-post-thumbnail category-main-dishes category-recipes category-vegetarian category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/general-tsos-cauliflower/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="General Tso&#039;s Cauliflower, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2015/10/general-tsos-cauliflower-5-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2015/10/general-tsos-cauliflower-5-300x400.jpg" class="entry-image attachment-post" alt="General Tso&#039;s Cauliflower, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/general-tsos-cauliflower/">General Tso&#8217;s Cauliflower</a></h2></header></article><article class="post-22366 post type-post status-publish format-standard has-post-thumbnail category-appetizers-and-snacks category-recipes category-vegetarian category-vegetables course-appetizer cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/chinese-zucchini-pancakes/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Chinese Zucchini Pancakes, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/07/chinese-zucchini-pancakes-10-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2018/07/chinese-zucchini-pancakes-10-300x400.jpg" class="entry-image attachment-post" alt="Chinese Zucchini Pancakes, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/chinese-zucchini-pancakes/">Chinese Zucchini Pancakes</a></h2></header></article><article class="post-23518 post type-post status-publish format-standard has-post-thumbnail category-gluten-free-recipes category-recipes category-side-dishes category-vegetarian category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/stir-fried-cabbage-glass-noodles/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Stir Fried Cabbage with Glass Noodles, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/11/cabbage-glass-noodles-11-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2018/11/cabbage-glass-noodles-11-300x400.jpg" class="entry-image attachment-post" alt="Stir Fried Cabbage with Glass Noodles, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/stir-fried-cabbage-glass-noodles/">Easy Stir Fried Cabbage with Glass Noodles</a></h2></header></article><article class="post-17423 post type-post status-publish format-standard has-post-thumbnail category-recipes category-side-dishes category-vegetarian category-vegetables archive-single entry"><a href="https://thewoksoflife.com/broccoli-garlic-sauce/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Takeout-Style Broccoli with Garlic Sauce, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2017/03/broccoli-garlic-sauce-8-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2017/03/broccoli-garlic-sauce-8-300x400.jpg" class="entry-image attachment-post" alt="Takeout-Style Broccoli with Garlic Sauce, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/broccoli-garlic-sauce/">Broccoli with Garlic Sauce, Takeout-Style</a></h2></header></article><article class="post-18340 post type-post status-publish format-standard has-post-thumbnail category-recipes category-salads category-vegetables course-salads cuisine-american archive-single entry"><a href="https://thewoksoflife.com/caesar-salad-kale/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Caesar Salad with Tuscan Kale, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2017/05/kale-caesar-salad-12-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2017/05/kale-caesar-salad-12-300x400.jpg" class="entry-image attachment-post" alt="Caesar Salad with Tuscan Kale, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/caesar-salad-kale/">Caesar Salad with Tuscan Kale</a></h2></header></article><article class="post-21784 post type-post status-publish format-standard has-post-thumbnail category-recipes category-side-dishes category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/dry-pot-cauliflower/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Chinese Dry Pot Cauliflower, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/05/dry-pot-cauliflower-8-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2018/05/dry-pot-cauliflower-8-300x400.jpg" class="entry-image attachment-post" alt="Chinese Dry Pot Cauliflower, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/dry-pot-cauliflower/">Dry Pot Cauliflower</a></h2></header></article><article class="post-4162 post type-post status-publish format-standard has-post-thumbnail category-recipes category-side-dishes category-vegetarian category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/stir-fried-pink-amaranth-greens/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Stir-fried Pink Amaranth Greens by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2014/04/amaranth-stir-fry-11-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2014/04/amaranth-stir-fry-11-300x400.jpg" class="entry-image attachment-post" alt="Stir-fried Pink Amaranth Greens by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/stir-fried-pink-amaranth-greens/">Stir-fried Pink Amaranth Greens &#8211; Chinese Spinach</a></h2></header></article><article class="post-36591 post type-post status-publish format-standard has-post-thumbnail category-quick-and-easy category-recipes category-side-dishes category-vegetarian category-vegetables archive-single entry"><a href="https://thewoksoflife.com/king-oyster-mushroom-stir-fry-vegan/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Spicy King Oyster Mushroom Stir-fry, thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2020/03/king-oyster-mushroom-stir-fry-10-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2020/03/king-oyster-mushroom-stir-fry-10-300x400.jpg" class="entry-image attachment-post" alt="Spicy King Oyster Mushroom Stir-fry, thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/king-oyster-mushroom-stir-fry-vegan/">Spicy King Oyster Mushroom Stir-fry (Vegan!)</a></h2></header></article></div></section><section id="text-98" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><h4 class="widget-title widgettitle"><a href="/category/recipes/quick-and-easy/">Try These Quick and Easy Dishes!<span class="alignright">See All</span></a></h4></div></div></section><section id="featured-post-4" class="widget featured-content featuredpost"><div class="widget-wrap"><article class="post-6255 post type-post status-publish format-standard has-post-thumbnail category-fish-and-seafood category-main-dishes category-noodles-pasta-recipes category-quick-and-easy category-recipes course-noodles-and-pasta cuisine-american archive-single entry"><a href="https://thewoksoflife.com/soy-sauce-butter-pasta-shrimp-shiitakes/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Soy Sauce Butter Pasta with Shrimp and Shiitakes by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2014/08/soy-sauce-butter-pasta-5-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2014/08/soy-sauce-butter-pasta-5-300x400.jpg" class="entry-image attachment-post" alt="Soy Sauce Butter Pasta with Shrimp and Shiitakes by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/soy-sauce-butter-pasta-shrimp-shiitakes/">Soy Sauce Butter Pasta with Shrimp and Shiitakes</a></h2></header></article><article class="post-30418 post type-post status-publish format-standard has-post-thumbnail category-quick-and-easy category-recipes archive-single entry"><a href="https://thewoksoflife.com/ground-meat-recipes/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2019/07/ground-meat-recipe-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2019/07/ground-meat-recipe-300x400.jpg" class="entry-image attachment-post" alt="" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/ground-meat-recipes/">24 Easy Asian Ground Meat Recipes</a></h2></header></article><article class="post-11935 post type-post status-publish format-standard has-post-thumbnail category-chinese-take-out category-eggs category-quick-and-easy category-recipes category-soups-and-stocks course-soups-and-stocks cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/egg-drop-soup/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Spoonful of egg drop soup, thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2019/05/egg-drop-soup-4-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2019/05/egg-drop-soup-4-300x400.jpg" class="entry-image attachment-post" alt="Spoonful of egg drop soup, thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/egg-drop-soup/">Egg Drop Soup</a></h2></header></article><article class="post-36249 post type-post status-publish format-standard has-post-thumbnail category-condiments category-quick-and-easy category-recipes archive-single entry"><a href="https://thewoksoflife.com/how-to-make-five-spice-powder/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Homemade Five Spice Powder, thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2019/12/five-spice-powder-6-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2019/12/five-spice-powder-6-300x400.jpg" class="entry-image attachment-post" alt="Homemade Five Spice Powder, thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/how-to-make-five-spice-powder/">How to Make Five Spice Powder</a></h2></header></article><article class="post-13971 post type-post status-publish format-standard has-post-thumbnail category-gluten-free-recipes category-main-dishes category-noodles-pasta-recipes category-quick-and-easy category-recipes course-noodles-and-pasta cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/glass-noodles-pork-napa-cabbage/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Braised Glass Noodles with Pork &amp; Napa Cabbage, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2016/04/glass-noodles-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2016/04/glass-noodles-300x400.jpg" class="entry-image attachment-post" alt="Braised Glass Noodles with Pork &amp; Napa Cabbage, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/glass-noodles-pork-napa-cabbage/">Braised Glass Noodles with Pork &#038; Napa Cabbage</a></h2></header></article><article class="post-10922 post type-post status-publish format-standard has-post-thumbnail category-chicken category-main-dishes category-quick-and-easy category-recipes course-chicken cuisine-tahi archive-single entry"><a href="https://thewoksoflife.com/red-curry-chicken/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Red Curry Chicken, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2015/07/red-curry-chicken-6-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2015/07/red-curry-chicken-6-300x400.jpg" class="entry-image attachment-post" alt="Red Curry Chicken, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/red-curry-chicken/">Red Curry Chicken Recipe</a></h2></header></article><article class="post-35446 post type-post status-publish format-standard has-post-thumbnail category-main-dishes category-quick-and-easy category-recipes category-steamed-dishes category-tofu category-vegetarian archive-single entry"><a href="https://thewoksoflife.com/steamed-tofu-mushrooms-hunan-spicy/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Hunan Steamed Tofu with Mushrooms and Duo Jiao, thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2019/11/steamed-tofu-salted-chili-11-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2019/11/steamed-tofu-salted-chili-11-300x400.jpg" class="entry-image attachment-post" alt="Hunan Steamed Tofu with Mushrooms and Duo Jiao, thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/steamed-tofu-mushrooms-hunan-spicy/">Spicy Hunan Steamed Tofu &#038; Mushrooms</a></h2></header></article><article class="post-18332 post type-post status-publish format-standard has-post-thumbnail category-main-dishes category-pork category-quick-and-easy category-recipes course-pork cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/garlic-chives-pork-cang-ying-tou/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="garlic chive stir fry with Pork, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2017/05/garlic-chives-stir-fry-2-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2017/05/garlic-chives-stir-fry-2-300x400.jpg" class="entry-image attachment-post" alt="garlic chive stir fry with Pork, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/garlic-chives-pork-cang-ying-tou/">Garlic Chive Stir Fry with Pork (Cang Ying Tou &#8211; 苍蝇头)</a></h2></header></article><article class="post-14268 post type-post status-publish format-standard has-post-thumbnail category-chicken category-noodles-pasta-recipes category-quick-and-easy category-recipes category-soups-and-stocks course-soups-and-stocks cuisine-japanese archive-single entry"><a href="https://thewoksoflife.com/udon-noodle-soup-chicken-mushrooms/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Udon Noodle Soup with Chicken &amp; Mushrooms, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2016/05/udon-noodle-soup-11-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2016/05/udon-noodle-soup-11-300x400.jpg" class="entry-image attachment-post" alt="Udon Noodle Soup with Chicken &amp; Mushrooms, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/udon-noodle-soup-chicken-mushrooms/">Udon Noodle Soup with Chicken &#038; Mushrooms</a></h2></header></article><article class="post-12750 post type-post status-publish format-standard has-post-thumbnail category-dim-sum category-quick-and-easy category-recipes category-side-dishes category-vegetarian category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/yu-choy-recipe/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Easy Yu Choy Recipe, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2015/12/choy-sum-6-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2015/12/choy-sum-6-300x400.jpg" class="entry-image attachment-post" alt="Easy Yu Choy Recipe, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/yu-choy-recipe/">Easy Chinese Yu Choy Sum</a></h2></header></article><article class="post-31675 post type-post status-publish format-standard has-post-thumbnail category-chicken category-chinese-take-out category-main-dishes category-quick-and-easy category-recipes archive-single entry"><a href="https://thewoksoflife.com/chinese-chicken-broccoli-brown-sauce/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Chicken and Broccoli Recipe, thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2019/05/chicken-with-broccoli-11-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2019/05/chicken-with-broccoli-11-300x400.jpg" class="entry-image attachment-post" alt="Chicken and Broccoli Recipe, thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/chinese-chicken-broccoli-brown-sauce/">Chicken and Broccoli with Brown Sauce</a></h2></header></article><article class="post-15252 post type-post status-publish format-standard has-post-thumbnail category-beef-recipes category-main-dishes category-noodles-pasta-recipes category-quick-and-easy category-recipes course-noodles-and-pasta cuisine-japanese archive-single entry"><a href="https://thewoksoflife.com/campfire-curry-ramen/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Campfire Curry Ramen - Easy Camping Meal, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2016/07/curry-ramen-4-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2016/07/curry-ramen-4-300x400.jpg" class="entry-image attachment-post" alt="Campfire Curry Ramen - Easy Camping Meal, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/campfire-curry-ramen/">Campfire Curry Ramen &#8211; An Easy Camping Meal</a></h2></header></article><article class="post-9463 post type-post status-publish format-standard has-post-thumbnail category-quick-and-easy category-recipes category-salads category-vegetarian category-vegetables archive-single entry"><a href="https://thewoksoflife.com/smashed-asian-cucumber-salad/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Smashed Asian Cucumber Salad, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2015/05/asian-cucumber-salad-5-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2015/05/asian-cucumber-salad-5-300x400.jpg" class="entry-image attachment-post" alt="Smashed Asian Cucumber Salad, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/smashed-asian-cucumber-salad/">Smashed Asian Cucumber Salad</a></h2></header></article><article class="post-21882 post type-post status-publish format-standard has-post-thumbnail category-eggs category-quick-and-easy category-rice-recipes course-quick-easy cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/weeknight-recipe-rice-avocado-eggs/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="weeknight recipe" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/05/chili-bamboo-shoots-12-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2018/05/chili-bamboo-shoots-12-300x400.jpg" class="entry-image attachment-post" alt="weeknight recipe" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/weeknight-recipe-rice-avocado-eggs/">Weeknight &#8220;Slop&#8221; (Rice with Eggs, Avocado &#038; Chili)</a></h2></header></article><article class="post-8320 post type-post status-publish format-standard has-post-thumbnail category-chinese-new-year category-quick-and-easy category-recipes category-side-dishes category-vegetarian category-vegetables course-vegetables cuisine-chinese archive-single entry"><a href="https://thewoksoflife.com/pea-tips-stir-fry/" class="aligncenter" aria-hidden="true" tabindex="-1"><img width="300" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20400'%3E%3C/svg%3E" class="entry-image attachment-post" alt="Pea Tips Stir-fry, by thewoksoflife.com" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2015/02/pea-tips-7-300x400.jpg" /><noscript><img width="300" height="400" src="https://thewoksoflife.com/wp-content/uploads/2015/02/pea-tips-7-300x400.jpg" class="entry-image attachment-post" alt="Pea Tips Stir-fry, by thewoksoflife.com" /></noscript></a><header class="entry-header"><h2 class="entry-title"><a href="https://thewoksoflife.com/pea-tips-stir-fry/">Pea Tips Stir-fry</a></h2></header></article></div></section></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="text-66" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Learn all about Chinese Noodles, Dumpling and Wonton Wrappers</h4><div class="textwidget"><a href="https://thewoksoflife.com/chinese-noodles-wrappers/" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20300'%3E%3C/svg%3E" nopin="nopin" width="300" height="300" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/01/noodles-and-wrappers-300.jpg" /><noscript><img src="https://thewoksoflife.com/wp-content/uploads/2018/01/noodles-and-wrappers-300.jpg" nopin = "nopin" width="300" height="300"/></noscript></a></div></div></section></div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="text-77" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="http://www.saveur.com/blog-awards-2015-winners?dom=specialinterest&src=2015blogbadge" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" nopin="nopin" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2015/06/Sav_EC_Badge.png" /><noscript><img src="https://thewoksoflife.com/wp-content/uploads/2015/06/Sav_EC_Badge.png" nopin = "nopin"/></noscript></a></div></div></section></div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="text-88" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Learn More About Chinese Leafy green Vegetables</h4><div class="textwidget"><a href="https://thewoksoflife.com/chinese-vegetables-asian-leafy-greens/" target="_blank" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20300'%3E%3C/svg%3E" nopin="nopin" width="300" height="300" data-lazy-src="https://thewoksoflife.com/wp-content/uploads/2018/01/chinese-leafy-green-300.jpg" /><noscript><img src="https://thewoksoflife.com/wp-content/uploads/2018/01/chinese-leafy-green-300.jpg" nopin = "nopin" width="300" height="300"/></noscript></a></div></div></section></div></div></div><footer class="site-footer"><div class="wrap"><div class="one-half first"><p>The Woks of Life LLC © 2013-&nbsp;2020 | <a href="https://thewoksoflife.com/privacy-policy">Privacy Policy</a></p></div><div class="one-half"><a href="#" class="back-to-top">Back to Top <i class="fa fa-long-arrow-up"></i></a></div></div></footer></div><div class="wprm-recipe-addendum" style="display:none; margin-top: 30px;"><p><strong>DID YOU MAKE THIS RECIPE?</strong><br> Our family wants to see it! Tag <strong>@thewoksoflife</strong> on Instagram and hashtag it <strong>#thewoksoflife!</strong></p><p><strong>LOOKING FOR UPDATES?</strong> <a href="https://mailchi.mp/thewoksoflife/end-post-subscribe" target="_blank">Subscribe to our email list</a> and/or follow us on <a href="https://www.instagram.com/thewoksoflife/" target="_blank">Instagram</a>, <a href="https://www.pinterest.com/thewoksoflife/" target="_blank">Pinterest</a>, and <a href="https://www.facebook.com/thewoksoflife/" target="_blank">Facebook</a>.</p></div> <script>(function($) {
    if($('.wprm-recipe-container').length) {
      $('.wprm-recipe-addendum').insertAfter('.wprm-recipe-container').show();
    }
    /* if($('.wprm-recipe-video-container').length) {
      $('.wprm-recipe-video-container').insertBefore('.wprm-recipe-container');
    }*/
  })(jQuery);</script> <script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script><script>(function (w, d) {
	var s = d.createElement('script');
	s.src = "https://dstik9906m659.cloudfront.net/eVIfRVUUblIfRlskRCEyUu.js";
	s.defer = true;
	d.body.appendChild(s);
})(window, document);</script> <script type="text/javascript" src="//downloads.mailchimp.com/js/signup-forms/popup/unique-methods/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script><script type="text/javascript">window.dojoRequire(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us7.list-manage.com","uuid":"c0ff269a59d4081b24338d690","lid":"02de1ed282","uniqueMethods":true}) })</script> <div class="ERSShare" style="display: none;"><p><strong>DID YOU MAKE THIS RECIPE?</strong><br /> Our family wants to see it! Tag <strong>@thewoksoflife</strong> on Instagram and hashtag it <strong>#thewoksoflife!</strong></p><p><strong>LOOKING FOR UPDATES?</strong> <a href="https://mailchi.mp/thewoksoflife/end-post-subscribe" target="_blank">Subscribe to our email list</a> and/or follow us on <a href="https://www.instagram.com/thewoksoflife/" target="_blank">Instagram</a>, <a href="https://www.pinterest.com/thewoksoflife/" target="_blank">Pinterest</a>, and <a href="https://www.facebook.com/thewoksoflife/" target="_blank">Facebook</a>.</div> <script>(function($) {

	if($('.ERSShare').length) {
		$('.ERSShare').insertAfter('.easyrecipe').show();
	}
	$(document).ready(function() {
		$('#simple-social-icons-2').appendTo('.widget_mc4wp_form_widget .signup-sidebar');
		$('.responsive-menu-icon').before($('.surprise-me-mobile'));
			$('.before-footer-widgets .featured-content .widget-wrap').prepend('<div class="cycle-prev"></div><div class="cycle-next"></div>');
		if ($(window).width() < 768) {
   			$('.before-footer-widgets .featured-content .widget-wrap').attr({'data-cycle-fx': 'carousel', 'data-cycle-carousel-visible': 2, 'data-cycle-carousel-fluid':true, 'data-cycle-slides' : ' > article', 'data-cycle-timeout':0, 'data-cycle-auto-height' : 'calc'});
		}	else {
		   $('.before-footer-widgets .featured-content .widget-wrap').attr({'data-cycle-fx': 'carousel', 'data-cycle-carousel-visible': 4, 'data-cycle-carousel-fluid':true, 'data-cycle-slides' : ' > article', 'data-cycle-timeout':0, 'data-cycle-auto-height' : 'calc'});
		}
		
		$('.before-footer-widgets .featured-content .widget-wrap').cycle({
			'fx': 'carousel', 
		});
		$('.ERSSavePrint').insertBefore('.ERSTopRight > img');
		});
	$(document).on('click', '.back-to-top', function(e) {
		e.preventDefault();
		$('html, body').animate({scrollTop: 0}, 1000);
	});

})(jQuery);</script> <style type="text/css" media="screen">#simple-social-icons-2 ul li a, #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus { background-color: #002d02 !important; border-radius: 0px; color: #ffffff !important; border: 0px #ffffff solid !important; font-size: 18px; padding: 9px; }  #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus { background-color: #e85c00 !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-2 ul li a:focus { outline: 1px dotted #e85c00 !important; }</style><script type="text/javascript">window.EASYINDEX = window.EASYINDEX || {};
    EASYINDEX.version = '1.1.1693';
    EASYINDEX.ajaxUrl = 'https://thewoksoflife.com/wp-admin/admin-ajax.php';
    EASYINDEX.thumbBase = "https://thewoksoflife.com/wp-content/uploads/easyindex";
    EASYINDEX.widgetData = '[]';</script> <script type='text/javascript'>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</script> <script type='text/javascript' async data-noptimize src='https://thewoksoflife.com/wp-content/cache/autoptimize/js/autoptimize_single_56cd2313818653301310cffe75b98ed9.js?ver=2.11.2'></script> <script type='text/javascript'>var wprm_public = {"settings":{"features_comment_ratings":true,"template_color_comment_rating":"#fecd00"},"home_url":"https:\/\/thewoksoflife.com\/","permalinks":"\/%postname%\/","ajax_url":"https:\/\/thewoksoflife.com\/wp-admin\/admin-ajax.php","nonce":"31b66df784","api_nonce":"9190cec1e8","translations":[]};</script> <script type='text/javascript'>var wprmp_public = {"endpoints":[],"settings":{"recipe_template_mode":"modern","features_adjustable_servings":true,"adjustable_servings_round_to_decimals":"2","features_comment_ratings":true,"features_user_ratings":false,"user_ratings_force_comment":"never","user_ratings_force_comment_scroll_to":"","servings_changer_display":"tooltip_slider","template_ingredient_list_style":"disc","template_instruction_list_style":"decimal","template_color_icon":"#343434"},"timer":{"sound_dir":"https:\/\/thewoksoflife.com\/wp-content\/plugins\/wp-recipe-maker-premium\/dist\/","text":{"start_timer":"Click to Start Timer"},"icons":{"pause":"<svg xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\" width=\"24px\" height=\"24px\" viewBox=\"0 0 24 24\"><g ><path fill=\"#fffefe\" d=\"M9,2H4C3.4,2,3,2.4,3,3v18c0,0.6,0.4,1,1,1h5c0.6,0,1-0.4,1-1V3C10,2.4,9.6,2,9,2z\"\/><path fill=\"#fffefe\" d=\"M20,2h-5c-0.6,0-1,0.4-1,1v18c0,0.6,0.4,1,1,1h5c0.6,0,1-0.4,1-1V3C21,2.4,20.6,2,20,2z\"\/><\/g><\/svg>","play":"<svg xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\" width=\"24px\" height=\"24px\" viewBox=\"0 0 24 24\"><g ><path fill=\"#fffefe\" d=\"M6.6,2.2C6.3,2,5.9,1.9,5.6,2.1C5.2,2.3,5,2.6,5,3v18c0,0.4,0.2,0.7,0.6,0.9C5.7,22,5.8,22,6,22c0.2,0,0.4-0.1,0.6-0.2l12-9c0.3-0.2,0.4-0.5,0.4-0.8s-0.1-0.6-0.4-0.8L6.6,2.2z\"\/><\/g><\/svg>","close":"<svg xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\" width=\"24px\" height=\"24px\" viewBox=\"0 0 24 24\"><g ><path fill=\"#fffefe\" d=\"M22.7,4.3l-3-3c-0.4-0.4-1-0.4-1.4,0L12,7.6L5.7,1.3c-0.4-0.4-1-0.4-1.4,0l-3,3c-0.4,0.4-0.4,1,0,1.4L7.6,12l-6.3,6.3c-0.4,0.4-0.4,1,0,1.4l3,3c0.4,0.4,1,0.4,1.4,0l6.3-6.3l6.3,6.3c0.2,0.2,0.5,0.3,0.7,0.3s0.5-0.1,0.7-0.3l3-3c0.4-0.4,0.4-1,0-1.4L16.4,12l6.3-6.3C23.1,5.3,23.1,4.7,22.7,4.3z\"\/><\/g><\/svg>"}},"recipe_submission":{"max_file_size":671088640,"text":{"image_size":"The image file is too large","drop_image":"Drop an image"}}};</script> <style type="text/css">.wprm-recipe-template-woks-of-life-compact {
    margin: 20px auto;
    background-color: #fafafa; /*wprm_background type=color*/
    font-family: Helvetica, sans-serif; /*wprm_main_font_family type=font*/
    font-size: 0.9em; /*wprm_main_font_size type=font_size*/
    line-height: 1.5em !important; /*wprm_main_line_height type=font_size*/
    color: #333333; /*wprm_main_text type=color*/
    max-width: 100%;
}
.wprm-recipe-template-woks-of-life-compact a {
    color: #3498db; /*wprm_link type=color*/
}
.wprm-recipe-template-woks-of-life-compact p, .wprm-recipe-template-woks-of-life-compact li {
    font-family: Helvetica, sans-serif; /*wprm_main_font_family type=font*/
    font-size: 1em !important;
    line-height: 1.5em !important; /*wprm_main_line_height type=font_size*/
}
.wprm-recipe-template-woks-of-life-compact li {
    margin: 0 0 0 32px !important;
    padding: 0 !important;
}
.wprm-recipe-template-woks-of-life-compact ol, .wprm-recipe-template-woks-of-life-compact ul {
    margin: 0 !important;
    padding: 0 !important;
}
.wprm-recipe-template-woks-of-life-compact br {
    display: none;
}
.wprm-recipe-template-woks-of-life-compact .wprm-recipe-name,
.wprm-recipe-template-woks-of-life-compact .wprm-recipe-header {
    font-family: Helvetica, sans-serif; /*wprm_header_font_family type=font*/
    color: #000000; /*wprm_header_text type=color*/
    line-height: 1.3em; /*wprm_header_line_height type=font_size*/
}
.wprm-recipe-template-woks-of-life-compact h1,
.wprm-recipe-template-woks-of-life-compact h2,
.wprm-recipe-template-woks-of-life-compact h3,
.wprm-recipe-template-woks-of-life-compact h4,
.wprm-recipe-template-woks-of-life-compact h5,
.wprm-recipe-template-woks-of-life-compact h6 {
    font-family: Helvetica, sans-serif; /*wprm_header_font_family type=font*/
    color: #000000; /*wprm_header_text type=color*/
    line-height: 1.3em; /*wprm_header_line_height type=font_size*/
    margin: 0 !important;
    padding: 0 !important;
}
.wprm-recipe-template-woks-of-life-compact .wprm-recipe-header {
    margin-top: 1.2em !important;
}
.wprm-recipe-template-woks-of-life-compact h1 {
    font-size: 2em; /*wprm_h1_size type=font_size*/
}
.wprm-recipe-template-woks-of-life-compact h2 {
    font-size: 1.8em; /*wprm_h2_size type=font_size*/
}
.wprm-recipe-template-woks-of-life-compact h3 {
    font-size: 1.2em; /*wprm_h3_size type=font_size*/
}
.wprm-recipe-template-woks-of-life-compact h4 {
    font-size: 1em; /*wprm_h4_size type=font_size*/
}
.wprm-recipe-template-woks-of-life-compact h5 {
    font-size: 1em; /*wprm_h5_size type=font_size*/
}
.wprm-recipe-template-woks-of-life-compact h6 {
    font-size: 1em; /*wprm_h6_size type=font_size*/
}.wprm-recipe-template-woks-of-life-compact {
	border-style: solid; /*wprm_border_style type=border*/
	border-width: 1px; /*wprm_border_width type=size*/
	border-color: #777777; /*wprm_border type=color*/
	border-radius: 0px; /*wprm_border_radius type=size*/
	padding: 10px;
}

/* .wprm-recipe-video iframe {
    position: absolute;
    top: 0;
    left: 0;
    width: 100%;
    height: 100%;
}

.wprm-recipe-video {
    position: relative;
    padding-bottom: 56.25%;
    padding-top: 25px;
    height: 0;
    margin-bottom: 25px;
}
*/</style><script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;

            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;

                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );

                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };

                observer.observe(b, config);
            }
        }, false);</script><script defer src="https://thewoksoflife.com/wp-content/cache/autoptimize/js/autoptimize_8013541c8fa4c5776bf19a57a5b6f3f6.js"></script></body></html>
